Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223786 - Blurred panel and menu icons after update of "gnome-panel"
Summary: Blurred panel and menu icons after update of "gnome-panel"
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-artwork
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F8Target
TreeView+ depends on / blocked
 
Reported: 2007-01-22 14:19 UTC by Joachim Frieben
Modified: 2013-03-06 03:48 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-10-13 11:47:51 UTC


Attachments (Terms of Use)
Panel screenshot at 24px (deleted)
2007-01-22 14:20 UTC, Joachim Frieben
no flags Details
Panel screenshot at 32px (deleted)
2007-01-22 14:21 UTC, Joachim Frieben
no flags Details
Panel screenshot at 24px [FC5] (deleted)
2007-01-22 14:22 UTC, Joachim Frieben
no flags Details
Panel screenshot at 24px ["Crux" theme] (deleted)
2007-01-22 16:09 UTC, Joachim Frieben
no flags Details
Screenshot of "gnome-panel" with two instances of "gnome-terminal" using the default icon (deleted)
2007-04-02 07:35 UTC, Joachim Frieben
no flags Details
Panel screenshot demonstrating slight cropping of Fedora icon (deleted)
2007-10-13 21:19 UTC, Joachim Frieben
no flags Details

Description Joachim Frieben 2007-01-22 14:19:06 UTC
Description of problem:
After updating to the latest version of "gnome-panel", menu and panel
icons look blurred.

Version-Release number of selected component (if applicable):
gnome-panel-2.17.90-1.fc7

How reproducible:
Always

Steps to Reproduce:
1. Log in to "GNOME" session.
2. Check that panel size is actually 24 px.
  
Actual results:
Menu and panel icons look blurred.

Expected results:
Menu and panel icons look crisp as they used to do for earlier
versions of "gnome-panel" [up to "2.16.2-2.fc7"].

Additional info:
After setting the panel size to 32px, the albeit bigger icons
look crisp again. However, for "FCn" [n=1..6] and FC devel"
before this usually worked even at 24px and the corresponding
smaller icon size.

Comment 1 Joachim Frieben 2007-01-22 14:20:33 UTC
Created attachment 146179 [details]
Panel screenshot at 24px

Comment 2 Joachim Frieben 2007-01-22 14:21:20 UTC
Created attachment 146181 [details]
Panel screenshot at 32px

Comment 3 Joachim Frieben 2007-01-22 14:22:56 UTC
Created attachment 146182 [details]
Panel screenshot at 24px [FC5]

Comment 4 Ray Strode [halfline] 2007-01-22 14:44:04 UTC
is this for any icon theme? or just bluecurve?

Comment 5 Joachim Frieben 2007-01-22 16:09:27 UTC
Created attachment 146193 [details]
Panel screenshot at 24px ["Crux" theme]

That's right. When you got to the "Sound & Video" menu, then the
"Movie Player" icon looks much better. Btw, when I set the icon
theme to "Crux", even the "Bluecurve" icons look crisp, but they
now ressemble much their "FC3" precursors with only weak outline
(see attachment showing browser and mail client icons).

Comment 6 Joachim Frieben 2007-01-22 18:30:11 UTC
This looks exactly like bug 146980 that I had opened 2 years ago.
The icons also got blurred at some point, see attachment

  https://bugzilla.redhat.com/bugzilla/attachment.cgi?id=113903 .

The bug was identified in

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=146980#c18

and solved in

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=146980#c19 .

Bug was then fixed in "redhat-artwork-0.122-8" ;o)

Comment 7 Joachim Frieben 2007-03-02 20:02:11 UTC
Issue still present "gnome-panel-2.17.92-1.fc7". Should this bug
be reported upstream, or is this change of behaviour due to some
internal modifications?

Comment 8 Ray Strode [halfline] 2007-03-02 21:25:02 UTC
probably a redhat-artwork bug, reassigning.

Comment 9 Joachim Frieben 2007-03-24 14:57:14 UTC
As of 2007-03-24, the issue is still affecting current "Fedora" development.
Given the many "Bluecurve" icons used all over the place even when "Echo" is
chosen and the remaining time before "F7" freeze, it appears desirable to
have this issue fixed soon. This bug should be added to "F7Target".

Comment 10 Ray Strode [halfline] 2007-03-24 16:16:41 UTC
Adding to FC7Target

Comment 11 Joachim Frieben 2007-04-02 07:35:42 UTC
Created attachment 151405 [details]
Screenshot of "gnome-panel" with two instances of "gnome-terminal" using the default icon

Another strange thing is that the icon aspect changes when you change the
icon and then set it back to its initial value. In the screenshot, two
instances of "gnome-terminal" have been added to the panel. For the left
one, the icon has been changed and then reset to the original one which
is used by the right entry. However, now the aspect is quite different!

Comment 12 Joachim Frieben 2007-05-13 08:23:56 UTC
Issue still present with "redhat-artwork-7.0.0-4.fc7".

Comment 13 Joachim Frieben 2007-08-03 13:37:34 UTC
Are there any plans to fix this bug? I recall that there is fair number
of "Bluecurve" icons used even when the default theme is used. Current
version: redhat-artwork-7.0.0-10.fc8

This bug is still marked "F7Target" but should probably get reassigned
to "F8Target".

Comment 14 Ray Strode [halfline] 2007-10-12 15:50:04 UTC
we discussed this bug during the last desktop team meeting.  the problem is the
panel asks for 22px icons and a lot (although by no means all!) icons for the
panel are 24px, so they get scaled and blurry.

It's pretty easy to switch the icon size (it's a theme setting we could set in a
panel gtkrc or in our default gtkrc), but neither 22px or 24px works, because it
will leave part of the icons blurry.

Amusingly, setting it to 23px makes almost all the icons look clear, because for
23px icons we don't scale, we just pick the closest one.

Comment 15 Joachim Frieben 2007-10-13 11:02:42 UTC
Ah, this 23px hack has been a full success! Maybe not the 'official'
solution to the problem, but a quick and useful measure. Thanks!

Comment 16 Matthias Clasen 2007-10-13 11:08:19 UTC
I've built a different fix yesterday. Please try and see if it solves your
problem too.

Comment 17 Joachim Frieben 2007-10-13 11:47:51 UTC
Issue fixed in 'gnome-panel-2.20.0.1-6.fc9'.

Comment 18 Joachim Frieben 2007-10-13 21:19:09 UTC
Created attachment 226531 [details]
Panel screenshot demonstrating slight cropping of Fedora icon

I have to note that there is a downside to this patch which is that
certain [non-Bluecurve] icons get sonewhat bigger now and end up
being slightly cropped as in the case of the 'Fedora' logo.


Note You need to log in before you can comment on or make changes to this bug.