Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223775 - ssRawCpu* stays on 2^32-1 forever
Summary: ssRawCpu* stays on 2^32-1 forever
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp
Version: 4.4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jan Safranek
QA Contact:
URL:
Whiteboard:
: 204089 240598 261601 363681 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 12:35 UTC by James Lamb
Modified: 2018-10-19 23:00 UTC (History)
5 users (show)

Fixed In Version: RHBA-2007-0738
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-11-15 16:00:21 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2007:0738 normal SHIPPED_LIVE net-snmp bug fix update 2007-11-14 16:40:02 UTC

Description James Lamb 2007-01-22 12:35:02 UTC
Description of problem:

When I query a RH ES v4 u4 server using snmp for idle ticks which should
indicate that the server is loaded or not. After a large amount of uptime (circa
100days) the servers all report the idle ticks not increasing even though the
server has been idle for some time. If I run the following command  awk '/^cpu /
{print $5}' /proc/stat I can see that the counter is still incrementing but
snmpd reports

UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: 4294967295

When I query with the following OID enterprises.ucdavis.systemStats

No matter how long the system is up it will always report the variable
4294967295, even if the system is 100% idle.

I have done some extensive research and it looks as though the problem is
resolved with the following patch from the net-snmp cvs.

http://net-snmp.cvs.sourceforge.net/net-snmp/net-snmp/agent/mibgroup/ucd-snmp/vmstat.c?r1=5.7&r2=5.8


Version-Release number of selected component (if applicable):


How reproducible:
Very Easy.


Steps to Reproduce:
1. snmpwalk -v 2c -c private localhost  enterprises.ucdavis.systemStats | grep Idle
; sleep 60 ; snmpwalk -v 2c -c private localhost 
enterprises.ucdavis.systemStats | grep Idle
  
Actual results:

UCD-SNMP-MIB::ssCpuIdle.0 = INTEGER: 99
UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: 4294967295

Expected results:

UCD-SNMP-MIB::ssCpuIdle.0 = INTEGER: 99
UCD-SNMP-MIB::ssCpuRawIdle.0 = Counter32: [[4294967295]] 

Where the [[]] Number should have incremented as the server is idle.

Additional info:

This problem appears to occur in all Redhat EL v3 and v4 servers that we have
with huge
uptime. 

After reading around on the internet I have found several people with an
identical issue. From what It looks like this is the patch to resolve the problem. 

http://net-snmp.cvs.sourceforge.net/net-snmp/net-snmp/agent/mibgroup/ucd-snmp/vmstat.c?r1=5.7&r2=5.8&diff_format=c

There are also debian users with similar problems.

http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=308018

I have previously reported this problem on bugzilla #202044 for EL3. The 
problem appears to show up much sooner on our EL4 servers

Comment 1 Flavio Leitner 2007-03-12 15:28:43 UTC
Can we fix it for 4.6?

Comment 2 Jan Safranek 2007-06-04 14:21:52 UTC
*** Bug 204089 has been marked as a duplicate of this bug. ***

Comment 3 RHEL Product and Program Management 2007-06-09 13:25:05 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 Bryan Mason 2007-07-24 21:32:15 UTC
*** Bug 240598 has been marked as a duplicate of this bug. ***

Comment 9 Jan Safranek 2007-08-29 07:37:55 UTC
*** Bug 261601 has been marked as a duplicate of this bug. ***

Comment 10 errata-xmlrpc 2007-11-15 16:00:21 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0738.html


Comment 11 Jan Safranek 2007-12-13 13:16:28 UTC
*** Bug 363681 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.