Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223759 - Kernel hanged
Summary: Kernel hanged
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: ia64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: fedora-ia64
TreeView+ depends on / blocked
 
Reported: 2007-01-22 08:20 UTC by Zhang Yanmin
Modified: 2007-12-18 16:30 UTC (History)
1 user (show)

Fixed In Version: 2.6.23.1-42.fc8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-12-18 16:30:21 UTC


Attachments (Terms of Use)
Boot log of kernel kernel-2.6.19-1.2914.fc7.ia64.rpm (deleted)
2007-01-29 09:09 UTC, Zhang Yanmin
no flags Details
New log of kernel 2.6.20-1.2922 panic (deleted)
2007-02-12 09:03 UTC, Zhang Yanmin
no flags Details

Description Zhang Yanmin 2007-01-22 08:20:29 UTC
Description of problem:
I used rpm to install the latest kernel and it hanged when rebooting.
The output:
Kernel panic - not syncing: No init found. Try passing init=option to kernel

Version-Release number of selected component (if applicable):
kernel-2.6.19-1.2912.fc7.ia64.rpm

How reproducible:
Everytime

Steps to Reproduce:
1. Use yum to upadte mkinitrd on my FC6 ia64 machine.
2. Run #rpm -ivh kernel-2.6.19-1.2912.fc7.ia64.rpm
3. Reboot
  
Actual results:
Hanged.

Expected results:
Kernel boots well.

Additional info:
1) I checked initrd.img and found there is an init script.

Comment 1 Prarit Bhargava 2007-01-22 16:35:12 UTC
Yanmin, could you attach the console log so I can see where the hang was?

Or does the system not boot the kernel at all?

P.

Comment 2 Zhang Yanmin 2007-01-23 03:37:06 UTC
Prarit,

The system could boot kenel, but kernel couldn't find /init. So it looks like an
initrd issue. I did an initial check of initrd.img and didn't find anything
abnormal.


I tried to capture log by serial port, but it didn't work. Below is something I
copied from the console.

Yanmin

*********************log********************
Net:Registered protocol
Freeing unused kernel memory:1888kb freed
Failed to execute /init
Kernel panic - not syncing: No init found. Try passing init=option to kernel



Comment 3 Zhang Yanmin 2007-01-29 09:08:09 UTC
I tried kernel-2.6.19-1.2914.fc7.ia64.rpm. Kernel hanged on one of my
machine(Montecito+Fusion SCSI disk). Pls. see the attached log.

Comment 4 Zhang Yanmin 2007-01-29 09:09:51 UTC
Created attachment 146812 [details]
Boot log of kernel kernel-2.6.19-1.2914.fc7.ia64.rpm

Comment 5 Zhang Yanmin 2007-02-12 09:03:39 UTC
Created attachment 147878 [details]
New log of kernel 2.6.20-1.2922 panic

I rebuilt kernel 2.6.20-1.2922 with patch of ata/ata_piix to convert GSI to
irq.

Then, rebuilt a new DVD image. kernel panic on my tige-4 Montecito machine.

With the same vmlinuz/initrd, my Madison machine and Hitachi machine don't
panic.

My Hitachi machine is also Montecito. processor info:
arch	   : IA-64
family	   : 32
model	   : 0
model name : Intel(r) Itanium(r) 2 Processor 1.6GHz with 24M L3 Cache for
533MHz Platforms
revision   : 5
archrev    : 0


Tiger-4 Montecito machine processor info:
arch	   : IA-64
family	   : 32
model	   : 0
revision   : 4
archrev    : 0

Comment 6 Zhang Yanmin 2007-02-12 09:10:28 UTC
Another difference between my Hitachi and tiger-4 is I disable multi-thread on
hitachi and enable it on tiger-4, because hitachi booting becomes very slow if I
turn on multi-thread.

Comment 7 Dave Jones 2007-05-15 20:25:41 UTC
is this reproducable with f7test4 ?
There were a large number of mkinitrd fixes just before its release which may
have helped.

Comment 8 Zhang Yanmin 2007-05-17 02:38:46 UTC
Dave,

Sorry. I'm very busy in other tasks and have no time to check it.

Yanmin


Comment 9 Doug Chapman 2007-12-18 16:30:21 UTC
This has been verified to be resolved on the F8 kernel.



Note You need to log in before you can comment on or make changes to this bug.