Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223757 - anaconda used an incorrect sequence to install mkinitrd, kernel and nash
Summary: anaconda used an incorrect sequence to install mkinitrd, kernel and nash
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 08:06 UTC by Zhang Yanmin
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-29 19:43:29 UTC


Attachments (Terms of Use)
/root/install.log (deleted)
2007-01-22 08:06 UTC, Zhang Yanmin
no flags Details

Description Zhang Yanmin 2007-01-22 08:06:06 UTC
Description of problem:
I built up a new dvd images from the latest development tree and installed it to 
my ia64 box by nfs. I walked around bug #222840 by replacing netIPv4/6 with
fixed value 1. Then, the installation went ahead, but initrd was lost when
installing kernel.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.9-1

How reproducible:
Everytime

Steps to Reproduce:
1.Rebuilup dvd image from the latest development tree;
2.Install os on the machine by choosing nfs method;
3. When installing kernel, anaconda looked hanged for more than 10 minutes;


  
Actual results:
After installation, reboot machine, machine hanged.


Expected results:
Machine shouldn't hang when rebooting

Additional info:
1) I checked the partition and found initrd was missed.
2) I checked /root/install.log and found mkinitrd reported it couldn't find
/sbin/nash. Checking the rpm installation sequence written in /root/install.log,
I saw that anaconda installed mkinitrd firstly, then kernel, then nash, while it
installed many other rpms among them.
3) The correct sequence should be: nash, mkinitrd, kernel.

Comment 1 Zhang Yanmin 2007-01-22 08:06:06 UTC
Created attachment 146156 [details]
/root/install.log

Comment 2 Jeremy Katz 2007-01-29 19:43:29 UTC
This was due to a bug in pkgorder that was fixed the end of last week


Note You need to log in before you can comment on or make changes to this bug.