Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223754 - wget --mirror fails to retrieve files on FTP site
Summary: wget --mirror fails to retrieve files on FTP site
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: wget
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Karsten Hopp
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 07:04 UTC by Chris Foote
Modified: 2016-03-22 13:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-12 13:30:13 UTC


Attachments (Terms of Use)
wget session log with debugging (deleted)
2007-01-22 07:04 UTC, Chris Foote
no flags Details

Description Chris Foote 2007-01-22 07:04:55 UTC
Description of problem:
wget fails to retrieve files from FTP servers with the --mirror
option.  It occurs on authenticated FTP sites and anonymous ones, with
or without a trailing directory path.

Version-Release number of selected component (if applicable):
wget.i386 1.10.2-3.3.fc5

How reproducible:
Always.

Steps to Reproduce:
1. wget -d --mirror ftp://filearena.net/pub/ubcd/3.4/

Actual results:
Successfully logs in, gets a directory listing, stores it in Unix 'ls -l'
format, but does not retrieve any of the files.

Expected results:
Should download files and continue process for subdirectories recursively.

Additional info:
Independant of type of FTP server (only Unix based ones were tried, however).

Comment 1 Chris Foote 2007-01-22 07:04:56 UTC
Created attachment 146154 [details]
wget session log with debugging

Comment 2 Chris Foote 2007-01-22 07:09:33 UTC
I can confirm it is also buggy on Fedora Core 6 (pkg:wget-1.10.2-8.fc6.1).


Comment 3 Steve Malenfant 2007-01-22 16:13:45 UTC
I confirm this problem as well, this has happened in the last wget-1.10.2-8
only, so on of the fixes resulting in this recursive feature to not work anymore
in FTP mode.

- fix bugzilla #218211
- fix bugzilla #186195
- fix bugzilla #205723

Needs fixed please.  Elevate priority.

Comment 4 Karsten Hopp 2007-02-12 13:30:13 UTC
can you please test wget-1.10.2-15 from rawhide and reopen if this bug still
exists ?

Comment 5 Steve Malenfant 2007-02-12 14:21:42 UTC
I'm sorry, but where is rawhide?  The only version I could find is wget-1.10.2-
14.fc2 from February 5th 2006.  Also I couldn't install it because I couldn't 
find the dependency rtld(GNU_HASH).

Comment 6 Karsten Hopp 2007-02-12 14:50:50 UTC
There's currently a problem with the rawhide build scripts, a new tree will be
published when that's resolved. As for the dependency problems: get the SRPM
and run rpmbuild --rebuilt SRPM-filename. This takes care of the dependencies
and rebuilds the package with the libraries on your system.


Comment 7 Mike Grant 2007-02-14 15:06:00 UTC
I can confirm this fixes it for me on FC6 - tested with "wget -r -l2 -P/tmp
ftp://wuarchive.wustl.edu/" from the wget man page.  With wget-1.10.2-8 this
retrieves the .listing and exits, with wget-1.10.2-15 it downloads the other
files too.

Comment 8 Steve Malenfant 2007-02-14 15:57:34 UTC
Tried on FC4 and FC5 and worked fine after re-compiling 1.10.2-15.


Note You need to log in before you can comment on or make changes to this bug.