Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223740 - USB boot can't load rescue image over NFS
Summary: USB boot can't load rescue image over NFS
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 02:59 UTC by Jerry Williams
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-29 19:41:13 UTC


Attachments (Terms of Use)

Description Jerry Williams 2007-01-22 02:59:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; (R1 1.1); .NET CLR 1.1.4322; FDM; .NET CLR 2.0.50727)

Description of problem:
When I boot from USB flash drive and select:
Rescue installed system

It starts running anaconda and then dies
It terminates things and says you may safely reboot your system.

This is using the current rawhide diskboot.img file.


Version-Release number of selected component (if applicable):
anaconda-11.2.0.13-1

How reproducible:
Always


Steps to Reproduce:
1. When I boot from USB flash drive and select: Rescue installed system
2. Select English
3. Select us
4. Select NFS image
5. Enable IPv4 support, Dynamic IP configuration (DHCP)
6. Disable IPv6 support
7. Enter NFS server name:
8. Fedora Core directory:
9. It starts running anaconda and then dies


Actual Results:
Traceback (most recent call last):
File "/usr/bin/anaconda", line 694, in <module>
rescue.runRescue(anaconda)
File "/usr/lib/anaconda/rescue.py" line 272, in runRescue
anaconda.setMethod()
TypeError: setMethod() takes exactly 2 arguments (1 given)
install exited abnormally [1/1]

Alt F2 shows:
-/bin/sh: error while loading shared libraries: libncurses.so.5: cannot open shared object file: No such file or directory

Expected Results:
would continue to load and look for my fedora core installation

Additional info:
from: rescue.py
    271     anaconda.intf = RescueInterface(screen)
    272     anaconda.setMethod()

Looks like it is trying to do something with the screen and can't find the libncurses.so.5 library.

Only see:
lrwxrwxrwx 1 root root     18 Jan 21 02:54 libncursesw.so.5 -> libncursesw.so.5.6
-r-xr-xr-x 1 root root 246904 Jan 21 02:54 libncursesw.so.5.6
in /usr/lib in minstg2.img file

Comment 1 Jeremy Katz 2007-01-29 19:41:13 UTC
Fixed this last week.


Note You need to log in before you can comment on or make changes to this bug.