Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223734 - pirut: rpmdb open failed
Summary: pirut: rpmdb open failed
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 01:51 UTC by 37gry8pr
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-29 18:59:58 UTC


Attachments (Terms of Use)

Description 37gry8pr 2007-01-22 01:51:47 UTC
Description of problem:
Running "Add/Remove Software" from KDE start. Get failure as noted above. 

Version-Release number of selected component (if applicable):


How reproducible:
Every Time

Steps to Reproduce:
1. Start package from start window
2. Put in root password.
3. Failure
  
Actual results:

Component: Software Manager
Summary: TBc3704fb6 config.py:656:_getsysver:TypeError: rpmdb open failed

Traceback (most recent call last):
  File "/usr/sbin/pirut", line 445, in ?
    main()
  File "/usr/sbin/pirut", line 438, in main
    pm = PackageManager(options.config)
  File "/usr/sbin/pirut", line 60, in __init__
    GraphicalYumBase.__init__(self, False, config)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 124, in __init__
    plugin_types=(yum.plugins.TYPE_CORE,))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 125, in
doConfigSetup
    self.conf = config.readMainConfig(startupconf)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 597, in readMainConfig
    vars['releasever'] = _getsysver(startupconf.installroot,
startupconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 656, in _getsysver
    idx = ts.dbMatch('provides', distroverpkg)
TypeError: rpmdb open failed

Local variables in innermost frame:
installroot: /
ts: <rpmUtils.transaction.TransactionWrapper instance at 0xa0b358c>
distroverpkg: redhat-release

Expected results:


Additional info:

"ls -l" listing of /var/lib/rpm:

[root@bigbox n6nko]# ls -l /var/lib/rpm
total 60052
-rw-r--r-- 1 rpm  rpm  10539008 Jan 21 10:12 Basenames
-rw-r--r-- 1 rpm  rpm     12288 Jan 21 07:29 Conflictname
-rw-r--r-- 1 root root        0 Jan 21 10:12 __db.000
-rw-r--r-- 1 root root    24576 Jan 21 10:06 __db.001
-rw-r--r-- 1 root root  1318912 Jan 21 10:06 __db.002
-rw-r--r-- 1 root root   450560 Jan 21 10:06 __db.003
-rw-r--r-- 1 rpm  rpm   1961984 Jan 21 10:12 Dirnames
-rw-r--r-- 1 rpm  rpm  10530816 Jan 21 10:12 Filemd5s
-rw-r--r-- 1 rpm  rpm     40960 Jan 21 10:12 Group
-rw-r--r-- 1 rpm  rpm     24576 Jan 21 10:12 Installtid
-rw-r--r-- 1 rpm  rpm     45056 Jan 21 10:12 Name
-rw-r--r-- 1 rpm  rpm  40357888 Jan 21 10:12 Packages
-rw-r--r-- 1 rpm  rpm    335872 Jan 21 10:12 Providename
-rw-r--r-- 1 rpm  rpm    114688 Jan 21 10:12 Provideversion
-rw-r--r-- 1 rpm  rpm     12288 Jan 21 07:36 Pubkeys
-rw-r--r-- 1 rpm  rpm    421888 Jan 21 10:12 Requirename
-rw-r--r-- 1 rpm  rpm    241664 Jan 21 10:12 Requireversion
-rw-r--r-- 1 rpm  rpm    167936 Jan 21 10:12 Sha1header
-rw-r--r-- 1 rpm  rpm     90112 Jan 21 10:12 Sigmd5
-rw-r--r-- 1 rpm  rpm     12288 Jan 20 13:45 Triggername
[root@bigbox n6nko]# ls

Comment 1 Jeremy Katz 2007-01-29 18:59:58 UTC

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.