Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223731 - suspend does not work on 2.6.19-1.2895 (worked great on 2.6.18-1.2869)
Summary: suspend does not work on 2.6.19-1.2895 (worked great on 2.6.18-1.2869)
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
Reported: 2007-01-22 00:50 UTC by zingale
Modified: 2008-08-02 23:40 UTC (History)
11 users (show)

Fixed In Version: F8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-03-09 06:54:42 UTC

Attachments (Terms of Use)

Description zingale 2007-01-22 00:50:31 UTC
Description of problem:

Using a Thinkpad X60, running FC6.  Suspend used to work great on this machine
(just close the lid).  Updated to 2.6.19-1.2895 and the suspend no longer
works.  I tried both by closing the lid and right clicking the battery icon 
on the gnome menubar and picking suspend.  The half-moon icon on the laptop
blinks steadily, but never stops blinking (as it should if the suspend were
successful).  And there is no way to recover, so I need to power off the machine.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. boot in 2.6.19-1.2895
2. try to suspend
3. it hangs
Actual results:

it hangs

Expected results:

should suspend gracefully

Additional info:

worked great in all kernels before this.  Continues to work if I boot into the
older 2.6.18-1.2869 kernel.

Comment 1 Brian G. Anderson 2007-01-22 01:17:16 UTC
Suspend stopped working on my Thinkpad T42p *and* my Dell 390 desktop.  Both
worked great on the previous 2.6.18-1.2869 kernel.  

Comment 2 Joshua Baker-LePain 2007-01-23 03:42:41 UTC
I'll add a me too on my Thinkpad Z61t -- suspend worked until the upgrade to
2.6.19-1.2895.  To the OP -- what mode is your hard drive in (in the BIOS)? 
Mine is in AHCI mode.  I'm wondering if that has anything to do with it.

Comment 3 Kent Engström 2007-01-23 19:48:53 UTC
Add me and my HP nc6400 laptop to the list. Suspend to RAM worked
with 2.6.18-1.2869.fc6 but with 2.6.19-1.2895.fc6 it hangs after a while
during the suspend process and I have to power off and reboot.

Comment 4 Rutger Noot 2007-01-24 09:23:28 UTC
Exactly the same thing on my transtec levio 210 (a pretty generic laptop). 

Comment 5 Christoph Höger 2007-01-26 12:07:51 UTC
Same thing here on my IBM Thinkpad R60.
I think the bug occurs in kernel/cpu.c

Comment 6 Paul W. Frields 2007-01-26 13:28:56 UTC
I'm pretty sure this is a duplicate of #223604.  Try doing '/sbin/service
cpuspeed stop' before your suspend and see if that nixes the problem.

Comment 7 Brian G. Anderson 2007-01-26 14:06:01 UTC
stopping cpuspeed worked for me.  My Dell 390 sleeps/resumes now.

Comment 8 zingale 2007-01-26 14:42:12 UTC
I agree that this does seem to fix things.  Just tried suspend to ram twice with
my thinkpad x60 (plugged into the power and using battery), and it worked fine
in both cases with cpuspeed stopped.

Comment 9 Tru Huynh 2007-02-16 17:45:50 UTC
stopping cpuspeed before suspending work around the suspend to ram on my Sony

Comment 10 Chuck Ebbert 2007-02-18 23:34:20 UTC
Can we push out an update to pm-utils that stops the cpuspeed service
before suspending???

Comment 11 Joshua Baker-LePain 2007-02-19 13:46:12 UTC
Is that the right fix, or just a band-aid?  I'm not trying to be snarky, I'm
actually wondering.  Did the in-kernel power management code change
fundamentally from 2.6.18-2.6.19 such that suspending with it enabled simply
won't ever work again?  Or is that something that should be fixed?

Comment 12 Phil Knirsch 2007-02-19 13:57:29 UTC
Well, imo it is some kinda of band aid. Suspend and hibernate have been a
feature for computers for a long time now and modules that still don't work
properly when suspending or hibernating it's really not the fault of the
userland but of those modules.

Especially in this case it used to work and then doesn't anymore. I'd have no
problem with voodoo hardware where drivers just can't be written to work
properly with suspend/hibernate because the hardware itself just can't cope with
it, but thats really broken hardware then.

Thats the reason why i'm very reluctant actually do add that change to pm-utils,
as the proper place to fix it would be the kernel.

Just my $0.02

Read ya, Phil

Comment 13 Chuck Ebbert 2007-02-19 16:56:09 UTC
The locking was changed in kernel 2.6.19 so that cpufreq updates
that used to be safe now cause an oops.

This cpu hotplug / cpufreq locking problem has been an ongoing issue
in the upstream kernel and is only being fixed properly in 2.6.21.

So yes, it's a band-aid but you'd have to wait for kernel 2.6.21
(or Fedora to backport those changes) to get the proper fix.
And the backport might cause new problems...

Comment 14 yerazunis 2007-03-09 18:13:42 UTC
This might also be the same as 230853 - failure to suspend on new kernel, when
it worked fine in a previous kernel.


Do we know what rev we have to drop back to for it to All Just Work?

Comment 15 Jon Stanley 2008-01-08 01:50:14 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)


I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

I am CC'ing myself to this bug, however this version of Fedora is no longer

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 16 Kent Engström 2008-01-08 08:34:01 UTC
> Add me and my HP nc6400 laptop to the list. Suspend to RAM worked
> with 2.6.18-1.2869.fc6 but with 2.6.19-1.2895.fc6 it hangs after a while
> during the suspend process and I have to power off and reboot.

I am now using Fedora 8 on the same laptop. Kernel: #1 SMP Fri Dec 7 15:49:59 EST 2007 i686 i686 i386 GNU/Linux

Both suspend to RAM and hibernate to disk seems to be working (shutdown OK,
getting back up also OK). The only thing I noticed as of yet is that I have
to make sure that "/sbin/hdparm -B254 /dev/sda" is run after the return to
life, otherwise I get the "Load Cycle incrementing too fast problem".

Comment 17 Jon Stanley 2008-03-09 06:54:42 UTC
In that case, I'll close this bug

Comment 18 Tru Huynh 2008-03-28 11:37:41 UTC
I can confirm that suspend is working out of the box.

Note You need to log in before you can comment on or make changes to this bug.