Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223728 - psacct logrotate file looks for non existant directory.
Summary: psacct logrotate file looks for non existant directory.
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: psacct
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ivana Varekova
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-22 00:33 UTC by Jerry Williams
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-23 09:42:16 UTC


Attachments (Terms of Use)

Description Jerry Williams 2007-01-22 00:33:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; (R1 1.1); .NET CLR 1.1.4322; FDM; .NET CLR 2.0.50727)

Description of problem:
Running psacct-6.3.2-42.fc7 and logrotate-3.7.4-10.fc7.
Getting email Subject: Anacron job for 'localhost' cron.daily /etc/cron.daily/logrotate:

Error: stat of /var/account/pacct failed: No such file or directory

Looks like /etc/logrotate.d/psacct belongs to the psacct package.

So if /etc/logrotate.d/psacct is going to look for /var/account/pacct, them 
maybe the packages should create the directory.


Version-Release number of selected component (if applicable):
psacct-6.3.2-42.fc7

How reproducible:
Always


Steps to Reproduce:
1.installed new OS
2.receive email about the problem.
3.

Actual Results:
Receive email:
Subject: Anacron job for 'localhost' cron.daily /etc/cron.daily/logrotate:

Error: stat of /var/account/pacct failed: No such file or directory



Expected Results:
Either psacct needs to create the directory or not look for it.

Additional info:

Comment 1 Ivana Varekova 2007-01-22 15:47:50 UTC
I try to reproduce your problem but I was unsuccesfull - 
Could you please attach the output of command 
ls -la /var/account/

Comment 2 Jerry Williams 2007-01-22 17:16:58 UTC
# ls -la /var/account/
total 16
drwxr-xr-x  2 root root 4096 2007-01-02 04:01 .
drwxr-xr-x 22 root root 4096 2007-01-20 16:04 ..

# rpm -q psacct
psacct-6.3.2-42.fc7

Well I decided to remove psacct with rpm -e psacct and then I did a
yum install psacct and now the file is there.
# ls -la /var/account/
total 12
drwxr-xr-x  2 root root 4096 2007-01-22 10:13 .
drwxr-xr-x 22 root root 4096 2007-01-22 10:13 ..
-rw-r--r--  1 root root    0 2007-01-22 10:13 pacct
# rpm -q psacct
psacct-6.3.2-42.fc7

So it must be some kind of problem with a full install.

Comment 3 Jerry Williams 2007-01-23 03:55:46 UTC
Did another install on a different laptop.
Just let first box checked for office stuff and checked development tools
and did install and ls /var/account/ is empty.

Comment 4 Jerry Williams 2007-01-23 06:30:24 UTC
Found this in /root/install.log:
Installing psacct - 6.3.2-42.fc7.i386
/var/tmp/rpm-tmp.77045: line 10: touch: command not found
error: %post(psacct-6.3.2-42.fc7.i386) scriptlet failed, exit status 127


Comment 5 Ivana Varekova 2007-01-23 09:42:16 UTC
Thank you for your help. This problem is fixed in psacct-6.3.2-42.fc6 (and in
devel in psacct-6.3.2-43.fc7).


Note You need to log in before you can comment on or make changes to this bug.