Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223431 - IPv6 autoconfigure does not work with kernel-2.6.19-1.2895.fc6.x86_64
Summary: IPv6 autoconfigure does not work with kernel-2.6.19-1.2895.fc6.x86_64
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
: 225105 227989 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-19 09:45 UTC by Per Steinar Iversen
Modified: 2007-11-30 22:11 UTC (History)
6 users (show)

Fixed In Version: 2.6.19-1.2911.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-15 19:16:02 UTC


Attachments (Terms of Use)

Description Per Steinar Iversen 2007-01-19 09:45:41 UTC
Description of problem:

kernel-2.6.19-1.2895.fc6.x86_64 does not autoconfigure IPv6 at boot.
kernel-2.6.18-1.2869.fc6.x86_64 works ok.

Version-Release number of selected component (if applicable):

kernel-2.6.19-1.2895.fc6.x86_64

How reproducible:

Always.

Steps to Reproduce:
1. Install kernel-2.6.19-1.2895.fc6.x86_64
2. Boot
3.
  
Actual results:

No public IPv6 address found on eth0. The link-local one is present (fe80::...)

Expected results:

A public IPv6 address should be active on eth0

Additional info:

Running kernel-2.6.18-1.2869.fc6.x86_64 seems to be the best current workaround.

Comment 1 Tom Hughes 2007-01-20 00:48:23 UTC
I've seen this as well - the router discoery message seems to be sent, and radvd
seems to reply with a router advertisment message but it seems tobe ignored and
no address is allocated.

Comment 2 Eric Hopper 2007-01-20 20:02:06 UTC
I'm also having this exact same problem.


Comment 3 Pierre Ossman 2007-01-21 11:45:18 UTC
Apparently a fix in 2.6.19.2 (which I assumed has been merged into RH:s kernel)
broke this. The fix has been posted to netdev:

http://www.spinics.net/lists/netdev/msg22663.html

It would be nice if this could be included into the RPM in the near future.

Comment 4 Eric Hopper 2007-01-23 10:59:26 UTC
Can the severity of this be changed to high?  It should be at least 'high'
because this completely breaks almost any IPv6 LAN with FC 6 boxes on it.

Comment 5 Peter Bieringer 2007-02-09 11:59:42 UTC
Same problem hits me on an i686 kernel, not nice...

Comment 6 Chuck Ebbert 2007-02-09 14:42:57 UTC
Fixed in pending update kernel, built yesterday, should go into testing today.

Comment 7 Chuck Ebbert 2007-02-09 14:43:48 UTC
*** Bug 227989 has been marked as a duplicate of this bug. ***

Comment 8 Chuck Ebbert 2007-02-09 14:45:10 UTC
*** Bug 225105 has been marked as a duplicate of this bug. ***

Comment 9 Per Steinar Iversen 2007-02-13 15:02:08 UTC
Today kernel-2.6.19-1.2911.fc6.x86_64 appeared on updates-testing. It fixes the
problem on my machine at least.


Comment 10 Andreas Müller 2007-02-14 10:09:33 UTC
2911 fixes the problem on two i686 machines.

Comment 11 Eric Hopper 2007-02-15 19:14:42 UTC
It works for me on my dual processor 2.6.19-1.2911.fc6 system.

25 days lag between noticing a problem with the IPv6 equivalent of DHCP and
having it fixed seems a little ridiculous to me.  Should I simply not bother
with IPv6 on any of my networks since RedHat doesn't really want to support it?


Note You need to log in before you can comment on or make changes to this bug.