Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223355 - rpm in Intel x86_64 doesn't read /usr/lib/rpm/x86_64-linux/macros
Summary: rpm in Intel x86_64 doesn't read /usr/lib/rpm/x86_64-linux/macros
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-01-18 22:59 UTC by Jesse Keating
Modified: 2013-01-10 02:34 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-28 11:03:43 UTC


Attachments (Terms of Use)

Description Jesse Keating 2007-01-18 22:59:13 UTC
ARCHITECTURE AND OS:
build arch            : x86_64
compatible build archs: ia32e x86_64 noarch
build os              : Linux
compatible build os's : linux
install arch          : ia32e
install os            : Linux
compatible archs      : ia32e x86_64 athlon noarch amd64 i686 i586 i486 i386 fat
compatible os's       : linux

RPMRC VALUES:
macrofiles            :
/usr/lib/rpm/macros:/usr/lib/rpm/ia32e-linux/macros:/etc/rpm/macros.*:/etc/rpm/macros:/etc/rpm/ia32e-linux/macros:~/.rpmmacros

If I change /etc/rpm/platform to read x86_64-linux rather than ia32e-linux, it
will then look in the right place:

ARCHITECTURE AND OS:
build arch            : x86_64
compatible build archs: x86_64 noarch
build os              : Linux
compatible build os's : linux
install arch          : x86_64
install os            : Linux
compatible archs      : x86_64 amd64 athlon noarch i686 i586 i486 i386 fat
compatible os's       : linux

RPMRC VALUES:
macrofiles            :
/usr/lib/rpm/macros:/usr/lib/rpm/x86_64-linux/macros:/etc/rpm/macros.*:/etc/rpm/macros:/etc/rpm/x86_64-linux/macros:~/.rpmmacros

Jeremy thinks that ia32e-linux platform should still be looking in
x86_64-linux/macros for stuff.  We don't seem to provide an ia32e-linux/macros file.

Comment 1 Will Woods 2007-05-17 20:17:18 UTC
This seems to be unchanged in current rawhide - do we need this for release?
What happens if we fail to fix this?

Comment 2 Peter Gordon 2007-05-18 04:38:00 UTC
Will,

I may be missing something but it seems to me that this bug is not fixed in
recent rawhide. Though I find it a bit odd that my macrofiles setting now
references x86_64-linux directories instead of ia32e-linux:


ARCHITECTURE AND OS:
build arch            : x86_64
compatible build archs: ia32e x86_64 noarch
build os              : Linux
compatible build os's : linux
install arch          : ia32e
install os            : Linux
compatible archs      : ia32e x86_64 athlon noarch amd64 i686 i586 i486 i386 fat
compatible os's       : linux

RPMRC VALUES:
macrofiles            : /usr/lib/rpm/macros:/usr/lib/rpm/x86_64-linux/macros:/us
r/lib/rpm/redhat/macros:/etc/rpm/macros.*:/etc/rpm/macros:/etc/rpm/x86_64-linux/
macros:~/.rpmmacros


I have not altered /etc/rpm/platform from its default and the file still
contains a single line, reading "ia32e-redhat-linux".


Comment 3 Will Woods 2007-05-18 04:40:36 UTC
Same on my x86_64 machine(s) - I'm hoping Paul can help shed some light on
whether this needs fixing now or later. Paul?

Comment 4 Peter Gordon 2007-05-18 04:49:14 UTC
Oh wait a second, it seems that the bug was about the ia32e-linux platform not
looking in x86_64-linux/macros; but that is apparently fixed (?). 

Will, this does indeed seem to be fixed to the contrary of my earlier comment
#2; though I can't pin down exactly which E:V-R it was fixed in (if indeed it
was). Nothing in the %changelog seems to show a patch or fix applied. :|

Comment 5 Will Woods 2007-05-18 14:25:20 UTC
AFAIK this is not going to horribly break anyone's system, so we'll fix it with
an update soon after F7 is released.

Comment 6 Jeff Johnson 2007-05-18 17:33:36 UTC
The problem is fixed in the rpm-4.4.2-ia32e-install.patch which (appears) to
be first included in (these are cvs tags)
    rpm-4_4_2-27                    (revision: 1.1)

Comment 7 Gordon Messmer 2007-06-04 18:34:06 UTC
It does break the occasional spec, making it difficult for people to build
packages on x86 hosts.  For instance:
http://marc.info/?l=courier-users&m=117682266604494&w=2

Comment 8 Red Hat Bugzilla 2007-08-21 05:30:50 UTC
User pnasrat@redhat.com's account has been closed

Comment 9 Panu Matilainen 2007-08-22 06:34:30 UTC
Reassigning to owner after bugzilla made a mess, sorry about the noise...

Comment 10 Panu Matilainen 2007-08-28 11:03:43 UTC
Fixed in rpm-4.4.2.2(-rc1) in next rawhide push.


Note You need to log in before you can comment on or make changes to this bug.