Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 223210 - [ml_IN][cal] AM/PM shown as 00 in GUI and print
Summary: [ml_IN][cal] AM/PM shown as 00 in GUI and print
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-01-18 14:21 UTC by A S Alam
Modified: 2013-07-03 00:43 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-13 17:21:05 UTC


Attachments (Terms of Use)
Image for ml_IN's AM/PM (deleted)
2007-01-18 14:21 UTC, A S Alam
no flags Details
Screenshot with "00" and "30" minute markers being shown in 24hr day-view (deleted)
2007-01-25 12:19 UTC, Mayank Jain
no flags Details
Patch to get to the screenshot in previous comment. (deleted)
2007-01-25 12:47 UTC, Mayank Jain
no flags Details | Diff

Description A S Alam 2007-01-18 14:21:18 UTC
Description of problem:
in Cal with malayalam (ml_IN) language, AM/PM is shown as 00.

Version-Release number of selected component (if applicable):
evolution-2.9.5-2.fc7

How reproducible:
Everytime while using evolution

Steps to Reproduce:
1. run evolution in ml_IN.UTF-8
2. goto Cal
3. check DAY view's side for AM/PM
  
Actual results:
00/00

Expected results:
1) Screenshot attached
2) AM/PM in Malayalam, otherwise 00/00

Additional info:
adding 2 keywords

Comment 1 A S Alam 2007-01-18 14:21:18 UTC
Created attachment 145919 [details]
Image for ml_IN's AM/PM

Comment 2 Mayank Jain 2007-01-25 11:05:33 UTC
Just found out that "00" is shown for locales where time is show in 24hr format,
12hr formats come properly.

Comment 3 Mayank Jain 2007-01-25 11:43:06 UTC
Actually, this is not a but, but a feature which looks bad when viewing the
calendar.

This is what i found in e-day-view-time-item.c:681
/* In 12-hour format we display 'am' or 'pm' instead of '00'. */

So, this "00" is the starting minutes of the event.
However, I agree with Aman that any user can confuse this 00 with a string
error. I'l trying to see whats the best solution out :)

Comment 4 Mayank Jain 2007-01-25 12:19:39 UTC
Created attachment 146529 [details]
Screenshot with "00" and "30" minute markers being shown in 24hr day-view

Comment 5 Mayank Jain 2007-01-25 12:47:25 UTC
Created attachment 146534 [details]
Patch to get to the screenshot in previous comment.

Comment 6 Mayank Jain 2007-01-25 12:49:57 UTC
So either this is not a bug or this patch can be good or we can remove the
minutes marker altogether from the display.

What do you think Matthew?

Comment 7 Christopher Aillon 2007-04-17 19:38:30 UTC
Not sure this is a bug, but we should figure this out before F7...

Comment 8 Matthias Clasen 2007-05-14 17:56:51 UTC
I'd say the minutes display could just be removed without a big loss of clarity.
But it is probably best to leave that decision to upstream.

Comment 9 Jens Petersen 2007-09-04 02:59:20 UTC
Based on attachment 146534 [details] I would say this is notabug.

Comment 10 Matthew Barnes 2007-09-13 17:21:05 UTC
Agreed, closing as such.


Note You need to log in before you can comment on or make changes to this bug.