Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 222849 - pirut crashes - TypeError: Can not update dbinfo table: database is locked
Summary: pirut crashes - TypeError: Can not update dbinfo table: database is locked
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: None
Product: Fedora
Classification: Fedora
Component: pirut
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-01-16 15:58 UTC by Saurabh Thakur
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-25 18:34:08 UTC


Attachments (Terms of Use)
it is the the dump report it produced (deleted)
2007-01-16 15:58 UTC, Saurabh Thakur
no flags Details
crash dump (deleted)
2007-01-25 12:44 UTC, Kent Cripps
no flags Details

Description Saurabh Thakur 2007-01-16 15:58:05 UTC
Description of problem:pirut crashes while retrieving update information


Version-Release number of selected component (if applicable):1.2.5-1


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Saurabh Thakur 2007-01-16 15:58:06 UTC
Created attachment 145697 [details]
it is the the dump report it produced

Comment 2 Kent Cripps 2007-01-25 12:44:44 UTC
Created attachment 146533 [details]
crash dump

PIRUT started from the applications menu. Root password entered. "Package
MAnager" window is drawn, and the "Retrieving software information" dialog is
opened.

The exception is raised when the "Retrieving software information" dialog is
approx 20% complete (on the progress bar).

Repeatable. Confirmed that yum-updatesd was not running at the time. Yum works
from command line.

Comment 3 Michael Schwendt 2007-01-25 17:31:04 UTC
Comment 2 is a different problem (a duplicate of bug 224292).

Changing summary for comment 1.

Comment 4 Jeremy Katz 2007-01-25 18:34:08 UTC

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.