Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2224 - lredir doesn't work
Summary: lredir doesn't work
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dosemu
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2225 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-17 02:54 UTC by Red Hat Bugzilla
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-13 03:40:59 UTC


Attachments (Terms of Use)

Description Red Hat Bugzilla 1999-04-17 02:54:06 UTC
According to the docs (README.txt), I should be able to
within dos type 'lredir' to show the maps.

I do, and I get:

C:\>lredir
ERROR: bad command or filename

Comment 1 Red Hat Bugzilla 1999-04-17 02:58:59 UTC
Oh, I see.

The problem is the default path isn't set to contain C:\DOSEMU .  That
might be a good idea.

Comment 2 Red Hat Bugzilla 1999-05-27 20:36:59 UTC
There's no autoexec.bat in the default dosemu. Therefore there is no
path.

Comment 3 Red Hat Bugzilla 1999-06-03 09:14:59 UTC
Adding an autoexec.bat with a mimimal configuration seems like
a good idea.

Comment 4 Red Hat Bugzilla 1999-06-09 17:14:59 UTC
*** Bug 2225 has been marked as a duplicate of this bug. ***

All the documentation files are difficult to read.  For
example, README.txt has text like this:

     l^Hla^Han^Hnc^Hch^Hhe^Hec^Hck^Hk.^H.e^Hex^Hxe^He
        ???

Bleah!

------- Additional Comments From dale@redhat.com  05/27/99 16:38 -------
They're like that in the source tar-ball. Shrug?

------- Additional Comments From jbj@redhat.com  06/03/99 05:12 -------
Distributing unreadable documentation because "that's what came with
the package" is silly.

Comment 5 Red Hat Bugzilla 1999-06-09 17:22:59 UTC
The distributed version of freedos would not read autoexec.bat and
config.sys. I updated to beta2 of freedos and now autoexec.bat and
config.sys are properly read.

Added a minimal config.sys and autoexec.bat to put c:\dosemu in the
path.

I now run s/.^H//g on all documentation to remove the ^H's.

Also added all of the freedos dos utilities and vim to the default
hdimage in dosemu-freedos. Now the distributed hdimage is actually
useable.

As an aside; lredir, although it is in the path now, will not work in
the distributed freedos hdimage. Generating a hdimage with msdos will
allow lredir to work if you load the emufs.sys driver in your
config.sys.

SRPM is waiting for jbj in my home directory
/home/saqadoc/dale/dosemu-0.99.10-6.src.rpm.

Comment 6 Red Hat Bugzilla 1999-06-13 03:40:59 UTC
Built for dist 6.1


Note You need to log in before you can comment on or make changes to this bug.