Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 221887 - Can't print locally with x86_64 systems
Summary: Can't print locally with x86_64 systems
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: hplip
Version: 6
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-01-08 19:06 UTC by Ed Friedman
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 1.6.12-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-02-05 14:22:11 UTC


Attachments (Terms of Use)

Description Ed Friedman 2007-01-08 19:06:12 UTC
Description of problem:


Version-Release number of selected component (if applicable):
cups-1.2.7-1.5.fc6

How reproducible: Always


Steps to Reproduce:
1.Connect local printer to computer with x86_64 kernel (or x86_64 kernel-xen)
either Pentium-D or Core 2 Duo
2.Use system-config-printer to set up printer (either HP2420D or Canon S530D)
using either Postscript or not
3.Try to print a test page
  
Actual results:
Nothing prints out

Expected results:
Test page should print out

Additional info:
There was no problem printing to a local printer when using a 32 bit CPU with 32
bit kernel.
When the printer was connected with a parallel cable, the following error
message kept repeating in /var/log/messages :

Jan  7 04:14:16 dickson hp_LaserJet_2420?serial=CNGJD22636: INFO: open device fa
iled; will retry in 30 seconds... 
Jan  7 04:14:46 dickson hp_LaserJet_2420?serial=CNGJD22636: unable to send Devic
eOpen: Broken pipe: prnt/hpijs/hplip_api.c 420 

When the printer was connected with a USB cable, the following error message
kept repeating in /var/log/messages :

Dec 31 04:28:25 dickson hpiod: unable to write MLCInit: Resource temporarily una
vailable io/hpiod/mlc.cpp 321 
Dec 31 04:28:25 dickson hpiod: error discarding URB: Invalid argument urb=0x6216
d0 io/hpiod/usbext.c 131
Dec 31 04:28:26 dickson hp_LaserJet_2420?serial=CNGJD22636: INFO: open print cha
nnel failed; will retry in 30 seconds...

Comment 1 Tim Waugh 2007-01-09 10:30:51 UTC
What does 'rpm -q hplip' say?

Comment 2 Ed Friedman 2007-01-09 19:40:20 UTC
hplip-1.6.10-1.fc6.4

Comment 3 Tim Waugh 2007-01-11 11:59:45 UTC
Please try 1.6.12-1.fc6 from updates-testing:

yum --enablerepo=updates-testing update 'hplip*' 'hpijs*' 'libsane-hpaio*'

Comment 4 Ed Friedman 2007-01-31 22:18:09 UTC
That fixed the problem for using usb local printers.  I still have the same
error message when using the local serial port, but that may be a problem with
that specific motherboard.  At this point, I am satisfied, since my local
printers can all connect via usb cables.

Comment 5 Ed Friedman 2007-03-16 17:01:46 UTC
The USB printers no longer print.  Both computers are using 64bit FC6 and both
automatically update through yum each night.  Obviously, some update broke the
previous fix.

There was no error message in /var/log/messages regarding this, and the
following is from /var/log/cups/error_log:

I [16/Mar/2007:11:55:02 -0500] Adding start banner page "none" to job 261.
I [16/Mar/2007:11:55:02 -0500] Adding end banner page "none" to job 261.
I [16/Mar/2007:11:55:02 -0500] Job 261 queued on "lp" by "root".
I [16/Mar/2007:11:55:02 -0500] Started filter /usr/lib/cups/filter/texttopaps (P
ID 14397) for job 261.
I [16/Mar/2007:11:55:02 -0500] Started filter /usr/lib/cups/filter/pstops (PID 1
4398) for job 261.
I [16/Mar/2007:11:55:02 -0500] Started backend /usr/lib/cups/backend/usb (PID 14
399) for job 261.


Comment 6 Tim Waugh 2007-03-16 17:38:24 UTC
Ed: please file a separate bug report.


Note You need to log in before you can comment on or make changes to this bug.