Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 221703 - Ligatures displayed incorrectly in Firefox
Summary: Ligatures displayed incorrectly in Firefox
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Martin Stransky
QA Contact:
URL:
Whiteboard:
: 236046 (view as bug list)
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2007-01-06 13:06 UTC by Nicolas Mailhot
Modified: 2007-11-30 22:11 UTC (History)
8 users (show)

Fixed In Version: 1.1.3-2.fc7
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-30 17:06:32 UTC


Attachments (Terms of Use)
backported changes from ff 1.5 (deleted)
2007-06-28 16:21 UTC, Martin Stransky
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Mozilla Foundation 331716 None None None Never

Description Nicolas Mailhot 2007-01-06 13:06:10 UTC
+++ This bug was initially created as a clone of Bug #187855 +++

Description of problem:
Firefox doesn't display the ligatures correctly. Need to have a font that
supports ligatures such as DejaVu for example. For a demo look at:
http://www.gnome.org/~jamesh/firefox-ligature.html

Version-Release number of selected component (if applicable):
firefox-2.0.1-1

Some history :

When DejaVu added ligatures characters to its font it was identified firefox
1.5+pango mishandled them. A bug was opened @moz & ligatures were disabled in
the font as a workaround (as a result the bug was hidden). Some googling shows
many other fonts are affected, but it only affects users of Fedora+pango

Recently since there was 0 activity on the bug mozilla-side the ligatures were
reenabled in FLOSS fonts. So fedora firefox is broken with the latest version of
its main font now. However behdad has written a patch that should fix this (not
publicised as the plan used to be firefox3 for F7)

Since the plan is now to go FF2 for F7, please include behdad's patch in Fedora
builds

Comment 1 Tomas Janousek 2007-02-04 13:27:04 UTC
Where is the behdad's patch?

Comment 2 Matthias Clasen 2007-04-05 19:08:46 UTC
Behdad, did you have a patch for ligatures in firefox ?

Comment 3 Behdad Esfahbod 2007-04-05 20:54:28 UTC
It's all in my nsFontMetricsPango rewrite that is in FC6.  Chris failed to port
it previously.  I'll start a FF2 build now and see what I can do.

Comment 4 Behdad Esfahbod 2007-04-11 22:40:49 UTC
*** Bug 236046 has been marked as a duplicate of this bug. ***

Comment 5 petrosyan 2007-06-06 00:52:41 UTC
Has this bug been fixed for Fedora 7?

Comment 6 Christopher Aillon 2007-06-06 00:55:36 UTC
Not yet... Martin can you look at doing the port of this from FC6 (1.5) to FC7
(2.0) ?

Comment 7 Martin Stransky 2007-06-06 06:51:57 UTC
okay, i'll do that

Comment 8 Martin Stransky 2007-06-28 09:48:35 UTC
The test case at http://www.gnome.org/~jamesh/firefox-ligature.html looks
broken. Is there any other?

Comment 9 Nicolas Mailhot 2007-06-28 11:06:29 UTC
Testcase is just trying to display text that includes ff or other ligaturable
combos with the browser configured (through CSS, etc) to use an opentype font
that includes ligatures (like dejavu sans). You can probably ask on #dejavu for
people to send you a sample text if the online testcase is dead

Comment 10 Martin Stransky 2007-06-28 11:08:09 UTC
no problem, i've got one from google cache.

Comment 11 Martin Stransky 2007-06-28 16:21:39 UTC
Created attachment 158138 [details]
backported changes from ff 1.5

There's a backported patch for nsFontMetricsPango class & FF2.

A testcase is here:

http://people.redhat.com/stransky/ligatures/test.html

The patch works fine for me (F7&FF2.0)

Comment 12 Martin Stransky 2007-06-28 16:23:15 UTC
Can anybody from pango gurus check it?

Comment 13 Behdad Esfahbod 2007-06-28 20:27:21 UTC
Thanks Martin.  Patch looks good.  I assume you ported it from the latest FC-6
patch, right?

Note the following two lines in fc6's firefox.spec:

pushd gfx/src/ps
  # This sort of sucks, but it works for now.
  ln -s ../gtk/nsFontMetricsPango.h .
  ln -s ../gtk/nsFontMetricsPango.cpp .
  ln -s ../gtk/mozilla-decoder.h .
  ln -s ../gtk/mozilla-decoder.cpp .
popd

That is supposed to fix the printing to use Pango.  So, please test printing
(test some MathML printing to file, before/after).

Other than that, got so say Thanks!

Can you please port other pango patches too?  I see a couple more in FC-6.

Finally, all should be applied to thunderbird too.

Comment 14 Martin Stransky 2007-06-29 12:21:18 UTC
(In reply to comment #13)
> Thanks Martin.  Patch looks good.  I assume you ported it from the latest FC-6
> patch, right?

Yep, I used a patch from ff 1.5.0.12

> Note the following two lines in fc6's firefox.spec:
> 
> pushd gfx/src/ps
>   # This sort of sucks, but it works for now.
>   ln -s ../gtk/nsFontMetricsPango.h .
>   ln -s ../gtk/nsFontMetricsPango.cpp .
>   ln -s ../gtk/mozilla-decoder.h .
>   ln -s ../gtk/mozilla-decoder.cpp .
> popd
> 
> That is supposed to fix the printing to use Pango.  So, please test printing
> (test some MathML printing to file, before/after).

I tested some examples from

http://www.mozilla.org/projects/mathml/demo/tester.html

the indic examples from Bug 129207 and ligature example and all looks fine. A
part of the printing patch was already ported to ff2.0.

> Other than that, got so say Thanks!
> 
> Can you please port other pango patches too?  I see a couple more in FC-6.

Done. These were applied w/o any conflict.

Chris - shall I build a ff package and put it into fedora 7 testing?



Comment 15 Martin Stransky 2007-07-09 10:21:09 UTC
Patches were added to firefox-2.0.0.4-3.fc7 and pushed into testing.

Comment 16 Fedora Update System 2007-07-09 15:46:55 UTC
firefox-2.0.0.4-3.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 17 petrosyan 2007-07-19 05:04:43 UTC
This bug has been fixed in firefox-2.0.0.5-1.fc7 package for Fedora 7.

Comment 18 Fedora Update System 2007-07-30 16:59:21 UTC
thunderbird-2.0.0.5-2.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.

Comment 19 Fedora Update System 2007-07-30 17:06:27 UTC
seamonkey-1.1.3-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 20 Fedora Update System 2007-09-18 03:24:05 UTC
thunderbird-2.0.0.5-2.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.