Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 221559 - clock-applet leaks memory
Summary: clock-applet leaks memory
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: rawhide
Hardware: All
OS: Linux
high
high
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target FC6Update
TreeView+ depends on / blocked
 
Reported: 2007-01-05 06:02 UTC by Sam Steingold
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-20 14:12:40 UTC


Attachments (Terms of Use)
Screenshot of "gnome-system-monitor" listing "clock-applet" (deleted)
2007-02-17 13:33 UTC, Joachim Frieben
no flags Details

Description Sam Steingold 2007-01-05 06:02:06 UTC
Description of problem:
clock-applet process grows to 50MB RSS over a couple of days

Version-Release number of selected component (if applicable):
gnome-panel-2.16.1-3.fc6

How reproducible:
always

Steps to Reproduce:
1.add clocc-applet to panel
2.wait for a couple of days
3.run "top", hit "M" to sort by RSS and observe this:

Mem:    742412k total,   545452k used,   196960k free,     8044k buffers
Swap:  1020116k total,   257536k used,   762580k free,   145220k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND            
21970 jenya     15   0 80656  54m 5188 S  0.0  7.6  10:18.96 clock-applet       
21966 sds       15   0 80664  54m 5220 S  0.3  7.6  10:03.37 clock-applet       
12415 sds       16   0  126m  50m  19m S  2.0  6.9   0:30.82 firefox-bin        
 9914 sds       15   0 48784  32m 3928 S  0.0  4.5   8:02.58 emacs              
 2711 root      15   0 75148  29m 4900 S  0.0  4.1  66:56.98 X                  
 2413 root      15   0  173m  28m 5936 S  4.6  4.0 150:57.29 X                  
 2501 sds       15   0  102m  28m 5388 S  0.0  3.9   5:03.85 wnck-applet        

 
Actual results:
clocc-applet (and wnck-applet) takes an unbelievable amount of RAM.
they are more hungry than firefox & emacs!


Expected results:
applets should not take more than 1-5 MB of RAM.

Additional info:

Comment 1 Sam Steingold 2007-01-08 17:28:57 UTC
I increased the priority because this bug impacts the system performance, 
so it affects other programs as well.

Comment 2 Matthias Clasen 2007-02-02 18:33:57 UTC
Does this still happen with 2.16.3 ?

Comment 3 Joachim Frieben 2007-02-17 13:33:49 UTC
Created attachment 148267 [details]
Screenshot of "gnome-system-monitor" listing "clock-applet"

This happens even for "gnome-panel-2.17.91-6.fc7". After 2 days of
uptime, the applet consumes 224 MB !!

Comment 4 Mamoru TASAKA 2007-03-24 06:14:35 UTC
Still happens on newest gnome-panel (FC-devel)
[tasaka1@localhost ~]$ LANG=C date ; ps auwwx | grep clock-applet | grep -v grep
Sat Mar 24 13:19:13 JST 2007
tasaka1  30102  2.7  2.0  44228 15292 ?        S    13:19   0:00
/usr/libexec/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockApplet_Factory
--oaf-ior-fd=25
[tasaka1@localhost ~]$ LANG=C date ; ps auwwx | grep clock-applet | grep -v grep
Sat Mar 24 13:33:51 JST 2007
tasaka1  30102  1.0  2.4  47724 18800 ?        S    13:19   0:09
/usr/libexec/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockApplet_Factory
--oaf-ior-fd=25
[tasaka1@localhost ~]$ LANG=C date ; ps auwwx | grep clock-applet | grep -v grep
Sat Mar 24 14:11:08 JST 2007
tasaka1  30102  1.1  3.6  56628 27732 ?        S    13:19   0:34
/usr/libexec/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockApplet_Factory
--oaf-ior-fd=25
[tasaka1@localhost ~]$ LANG=C date ; ps auwwx | grep clock-applet | grep -v grep
Sat Mar 24 15:09:55 JST 2007
tasaka1  30102  1.1  5.5  70744 41796 ?        S    13:19   1:15
/usr/libexec/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockApplet_Factory
--oaf-ior-fd=25
[tasaka1@localhost ~]$ LANG=C date ; ps auwwx | grep clock-applet | grep -v grep
Sat Mar 24 15:12:52 JST 2007
tasaka1  30102  1.1  5.6  71396 42492 ?        S    13:18   1:17
/usr/libexec/clock-applet --oaf-activate-iid=OAFIID:GNOME_ClockApplet_Factory
--oaf-ior-fd=25
[tasaka1@localhost ~]$ rpm -q gnome-panel
gnome-panel-2.18.0-1.fc7


Comment 5 Ray Strode [halfline] 2007-03-24 14:22:58 UTC
Adding to FC7Target

Comment 6 Mamoru TASAKA 2007-04-20 10:38:52 UTC
On the rawhide yesterday (2007 Apr 19), the symptom
of clock-applet seems to have disappeared......
Currently for several days clock-applet seems okay.

Comment 7 Matthias Clasen 2007-04-20 14:12:40 UTC
Ok, thanks for the update. Closing for now then. Please file a new bug if you
see something similar again.


Note You need to log in before you can comment on or make changes to this bug.