Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 220909 - Shutdown procedure forgets to do powerdown
Summary: Shutdown procedure forgets to do powerdown
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
Reported: 2006-12-28 19:18 UTC by The Source
Modified: 2008-08-02 23:40 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-03-09 06:42:50 UTC

Attachments (Terms of Use)

Description The Source 2006-12-28 19:18:03 UTC
Description of problem:
When I do system shutdown, system gets halted but power never switches off

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
Actual results:

Expected results:

Additional info:

Comment 1 Julien Tognazzi 2006-12-29 10:23:15 UTC
I also have this problem on one of my computer (my parent's one).
Since I installed FC6 on it, it never poweroff, but stalls either with the
desktop background, or after it shutted down the differents services.
The computer is a Thinkpad A22e.
I tried with a liveCD i had, and it powered off nicely...

Comment 2 The Source 2007-01-05 18:05:51 UTC
Bug still present in

Comment 3 The Source 2007-01-07 13:05:45 UTC
I suspect that this bug may be connected to use of smp kernel on
single-processor system. Can anyone confirm this?

Comment 4 The Source 2007-01-20 09:26:24 UTC
Bug still present in
Is that really so hard to fix it? This very annoying.

Comment 5 The Source 2007-01-24 16:25:01 UTC
powerdown does not work because acpi can not start. The error message is:
sbs: Unknown symbol acpi_get_ec_hc

Comment 6 The Source 2007-01-24 16:47:11 UTC
I tried to start all modules in drivers/acpi directory but all of them say no
such device

Comment 7 The Source 2007-01-26 13:51:06 UTC
My motherboard is 6VIA85T. Have you removed support for it? I also have APC UPS.
Can there be conflicts?

Comment 8 The Source 2007-03-03 14:02:47 UTC Still here. Can any one hear me?! Hello-o-o-o!! You could give me a
response at least.

Comment 9 Julien Tognazzi 2007-03-19 11:05:33 UTC
I tested the latest kernel 2.6.20-1.2925.fc6 with the thinkpad, and now it
powers off cleanly.

Comment 10 The Source 2007-03-19 12:16:34 UTC
Not for me. still has this bug on my system. My motherboard is
Acorp 6VIA85T. Perhaps your motherboard is now supported but not mine :(

Comment 11 Dave Jones 2007-03-19 19:34:20 UTC
Try removing some modules before doing the shutdown and see if that makes a
difference.  Top of the list of ones to try would be sbs i2c_ec and possibly the
usb modules (ehci_hcd and friends).

Comment 12 The Source 2007-04-13 07:07:49 UTC
Didn't help. After removing specified modules neither could I start acpi modules
(they all say 'no such device') nor shutdown properly.

Comment 13 The Source 2007-04-22 07:08:54 UTC
Please, check this dmesg output:
 BIOS-e820: 000000003fff0000 - 000000003fff3000 (ACPI NVS)
 BIOS-e820: 000000003fff3000 - 0000000040000000 (ACPI data)
ACPI: RSDP (v000 VIA694                                ) @ 0x000f61d0
ACPI: RSDT (v001 VIA694 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3fff3000
ACPI: FADT (v001 VIA694 AWRDACPI 0x42302e31 AWRD 0x00000000) @ 0x3fff3040
ACPI: DSDT (v001 VIA694 AWRDACPI 0x00001000 MSFT 0x0100000c) @ 0x00000000
ACPI: Disabling ACPI support
ACPI: Interpreter disabled.
pnp: PnP ACPI: disabled

I have ACPI anabled in bios, so there is something really wring with kernel.
Any ideas?

Comment 14 Jon Stanley 2008-01-08 01:53:49 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)


I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

I am CC'ing myself to this bug, however this version of Fedora is no longer

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 15 The Source 2008-01-08 07:46:45 UTC
I can't reproduce this because I now have much newer hardware. I won't close
this in case some one else can reproduce it. The problem was on Acorp 6VIA85T
motherboard, Intel P3 1200MHz.

Comment 16 Jon Stanley 2008-03-09 06:42:50 UTC
Since there are insufficient details provided in this report for us to
investigate the issue further, and we have not received feedback to the
information we have requested above, we will assume the problem was not
reproducible, or has been fixed in one of the updates we have released for the
reporter's distribution.

Users who have experienced this problem are encouraged to upgrade to the latest
update of their distribution, and if this issue turns out to still be
reproducible in the latest update, please reopen this bug with additional


Note You need to log in before you can comment on or make changes to this bug.