Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 220814 - kernel-2.6.18-1.2868.fc6 causing a kernel panic at boot
Summary: kernel-2.6.18-1.2868.fc6 causing a kernel panic at boot
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
 
Reported: 2006-12-27 13:31 UTC by Jongi
Modified: 2008-01-08 08:10 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-08 08:10:14 UTC


Attachments (Terms of Use)

Description Jongi 2006-12-27 13:31:21 UTC
Description of problem:

Here is what happens when I try to run kernel-2.6.18-1.2868.fc6 which I updated
using SMART. This is a desktop PC.

ACPI: Getting cpuindex for acpiid 0x1 
ACPI: Getting cpuindex for acpiid 0x2 
ACPI: Getting cpuindex for acpiid 0x3 
Red Hat Nash version 5.1.19.0.2 starting 
setuproot: moving /dev failed: No such file or directory 
setuproot: error mounting /proc: No such file or directory 
setuproot: error mounting /sys: No such file or directory 
ERROR opening /dev/console Trying to use fd 0 instead 
WARNING: can't access (null) 
exec of init ((null)) failed!!! Bad Address 
Kernel panic - not syncing: Attempted to kill init

The 2849 kernel works.

Version-Release number of selected component (if applicable):
kernel-2.6.18-1.2868.fc6

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jongi 2006-12-27 19:12:00 UTC
The solution to the problem was a simple one. There was one difference between
the 2849 and 2868 grub kernel lines. The 2849 had [b]root=LABEL=/[/b] whereas
2868 had [b]root=/dev/hdd6[/b]. Once I changed the 2868 line to reflect what the
2849 line was showing it booted without issues. 

I had previously seen the difference however I didn't think it would matter as
/dev/hdd6 is mounted as /. And it isn't part of a LVM physical volume, just a
reiserfs partition.

Comment 2 Jon Stanley 2008-01-08 01:50:08 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!


Note You need to log in before you can comment on or make changes to this bug.