Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 220614 - RFE: improve start time of yum-updatesd
Summary: RFE: improve start time of yum-updatesd
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-12-22 15:41 UTC by Thorsten Leemhuis
Modified: 2014-01-21 22:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-05-03 01:26:20 UTC


Attachments (Terms of Use)

Description Thorsten Leemhuis 2006-12-22 15:41:04 UTC
Description of problem:
I own a 2 1/2 year old laptop with Pentium M 1,5 GHz, 60 GB harddisk and ATI
Graphics. I the harddisk is quite slow, I know that, but it's normally fast
enough for normal use. But I noticed that yum-updatesd takes quite a while to
start due to the slow disk -- between 5 and 5,5 seconds round about. That's IMHO
far to much for a daemon that's started on boottime (thus I disabled it in between).

Version-Release number of selected component (if applicable):
yum-updatesd-3.0.1-2.fc6

How reproducible:
Always

Additional Informations:
[root@notebook ~]# time /etc/init.d/yum-updatesd start
Yum-Updatesd starten:                                      [  OK  ]

real    0m5.398s
user    0m0.514s
sys     0m0.126s
[root@notebook ~]# /etc/init.d/yum-updatesd stop
Yum-updatesd beenden:                                      [  OK  ]
[root@notebook ~]# time /etc/init.d/yum-updatesd start
Yum-Updatesd starten:                                      [  OK  ]

real    0m0.481s
user    0m0.263s
sys     0m0.051s
[root@notebook ~]#

Comment 1 Thorsten Leemhuis 2006-12-22 15:45:24 UTC
(In reply to comment #0)
> [root@notebook ~]# time /etc/init.d/yum-updatesd start

This first run was with cold cache ("echo 3 >/proc/sys/vm/drop_caches"). It's
probably a little bit faster during startup as some other things updatesd might
need are probably in the cache already, but it's not much faster afaics

Comment 2 Jeremy Katz 2007-01-03 16:58:47 UTC
Putting some dead simple timing, this is purely due to the various imports which
are done.  It looks like delaying imports until after we fork could cut the time
roughly in half

Comment 3 Bryan O'Sullivan 2007-04-27 03:56:13 UTC
This isn't just slow old hard disks; it's an issue on my spanking new desktop
and laptop systems, too.  yum-updatesd is the most visible component of boot
time :-(

Comment 4 Jeremy Katz 2007-05-03 01:26:20 UTC
Improved in yum CVS.

Time with cold cache on my laptop is now 2.8 seconds.  Cold cache to just start
the python interpreter and print hello world is 1.6 seconds.  So that seems
about as good as we're going to get.


Note You need to log in before you can comment on or make changes to this bug.