Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 220084 - yum failing to install with file:// based repo
Summary: yum failing to install with file:// based repo
Keywords:
Status: CLOSED DUPLICATE of bug 212180
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: yum
Version: 5.0
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-18 20:11 UTC by Dax Kelson
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-12-19 18:52:45 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Dax Kelson 2006-12-18 20:11:41 UTC
Description of problem:

I setup a repo with the following:

[RHEL5-Server]
name=RHEL $releasever - Server - $basearch
baseurl=file:///net/server1/export/netinstall/RHEL5/Server
enabled=1
gpgcheck=1
gpgkey=file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora
file:///etc/pki/rpm-gpg/RPM-GPG-KEY file:///etc/pki/rpm-gpg/RPM-GPG-KEY-beta

Commands like "yum list" and "yum search foo" work fine. However, when I try to
install something, it blows up:

# yum install bind-chroot
Loading "rhnplugin" plugin
Loading "installonlyn" plugin
This system is not registered with RHN.
RHN support will be disabled.
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for bind-chroot to pack into transaction set.
media://1163270928.939995%232/bind-chroot-9.3.3-5.el5.i386.rpm: [Errno 4]
IOError: <urlopen error unknown url type: media>
Trying other mirror.
Error: failed to retrieve bind-chroot-9.3.3-5.el5.i386.rpm from RHEL5-Server
error was [Errno 4] IOError: <urlopen error unknown url type: media>

Version-Release number of selected component (if applicable):
yum-3.0-5.4
yum-3.0.1-2.fc6

I opened a yum bug upstream at:
https://devel.linux.duke.edu/bugzilla/show_bug.cgi?id=677

Comment 1 Dax Kelson 2006-12-18 21:02:45 UTC
According to upstream this will be fixed in yum at some point. 

Being able to use the same directory tree to install from with anaconda and then
use with yum is extremely useful in a isolated network without RHN (not at all
uncommon).

Comment 2 Jeremy Katz 2006-12-19 18:52:45 UTC

*** This bug has been marked as a duplicate of 212180 ***


Note You need to log in before you can comment on or make changes to this bug.