Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 219919 - Constant RPM db corruption and dieing Yum & RPM processes
Summary: Constant RPM db corruption and dieing Yum & RPM processes
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-16 14:13 UTC by Draciron
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-17 12:52:39 UTC


Attachments (Terms of Use)
rebuild dirs from rpm (deleted)
2006-12-16 14:13 UTC, Draciron
no flags Details

Description Draciron 2006-12-16 14:13:06 UTC
Description of problem:

Constant RPM problems since going with FC6.  Did a fresh install of FC6. Then
updated with Yum. Then installed the rest of my normal packages. Left gnome-yum
up overnight once and yumupdate daemon was enabled. Tried to finish the installs
and the rpm database was hopelessly corrupted. Rebuilt the database and reran
the packages I wanted to install and things were good for a few days. Then doing
a yum update from the command line it went away and for 2 days I let it churn
before killing the process. Removed all the locks and was able to install ONLY
by removing locks for a time. Then had to rebuild the database. This most recent
rebuilddb effort lasted all of 2 days before the database was hopelessly
corrupted again. Still have yet to finish updating packages. Now when I try to
rebuild the DB I get a seg fault. 

When I ps for rpm these processes are ones I typically kill before removing the
locks and rebuilding the db. 
/usr/lib/rpm/rpmq -q --all --queryformat Name   :%{NAME}\nArch  
:%{ARCH}\nVersion:%{VERSION}\nRelease:%{RELEASE}\nSize   :%{SIZE}\nRepo  
:installed\nSummary:%{SUMMARY}\n\nDescription:\n%{DESCRIPTION}\n\n

/usr/lib/rpm/rpmq -q --all --qf %{name}-%{version}-%{release}.%{arch}.rpm\n

/bin/sh /etc/cron.daily/rpm

I normally have several copies of each. All sleeping processes, some started 3
or 4 days ago. 

I shut down the yum-updatesd daemon and made sure it was stopped thinking it was
the problem. This did not help. 




Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Draciron 2006-12-16 14:13:24 UTC
Created attachment 143853 [details]
rebuild dirs from rpm

Comment 2 Panu Matilainen 2007-07-17 12:52:39 UTC

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.