Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 219338 - md 32bit compat ioctls missing on 64bit kernels
Summary: md 32bit compat ioctls missing on 64bit kernels
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: ---
Assignee: Doug Ledford
QA Contact: Brian Brock
URL:
Whiteboard:
: 210175 (view as bug list)
Depends On:
Blocks: 234654 420521 422431 422441
TreeView+ depends on / blocked
 
Reported: 2006-12-12 17:17 UTC by Bryn M. Reeves
Modified: 2018-10-19 18:38 UTC (History)
2 users (show)

Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-21 14:40:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Add md bitmap compat ioctl support (deleted)
2006-12-12 17:19 UTC, Bryn M. Reeves
no flags Details | Diff


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0314 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5.2 2008-05-20 18:43:34 UTC

Description Bryn M. Reeves 2006-12-12 17:17:10 UTC
Description of problem:
When "mdadm --query" runs in a 32bit userspace on a 64bit kernel, compat ioctls
(ioctl32) are used to talk to the md driver. Support for md bitmap ioctls was
merged upstream in 2.6.19 but is missing from the RHEL5 kernels.

This leads to error messages in dmesg when "mdadm --query" runs.

Version-Release number of selected component (if applicable):
2.6.18-1.2714.el5

How reproducible:
100%

Steps to Reproduce:
1. Install 32bit mdadm on a system running a 64bit kernel
2. Run "mdadm --query /some/md/device"
  
Actual results:
error printed to dmesg/console:
ioctl32(mdadm:1776): Unknown cmd fd(3) cmd(50000915){10} arg(fa80e460) 

Expected results:
No errors reported in dmesg.

Additional info:
This was fixed upstream by the following commits:
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=da3ed32fe568148ede256975d40825ffcdac767b
http://www.kernel.org/git/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=d19c2ee0b8d1cd83f8bc0f1f5e94e6b6ec71ea10

Comment 1 Bryn M. Reeves 2006-12-12 17:19:31 UTC
Created attachment 143416 [details]
Add md bitmap compat ioctl support 

Patch merging the changes from the two git commits

Comment 5 RHEL Product and Program Management 2007-04-25 22:51:06 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 8 Doug Ledford 2007-11-30 15:39:33 UTC
*** Bug 210175 has been marked as a duplicate of this bug. ***

Comment 9 Jay Turner 2007-12-13 14:06:44 UTC
QE ack for RHEL5.2.  Reproducer in comment 0.

Comment 10 Don Zickus 2008-01-24 21:15:27 UTC
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 16 errata-xmlrpc 2008-05-21 14:40:24 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html



Note You need to log in before you can comment on or make changes to this bug.