Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2192 - /etc/X11/xinit/.Xmodmap should be Xmodmap and xmodmap backsapce
Summary: /etc/X11/xinit/.Xmodmap should be Xmodmap and xmodmap backsapce
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: xinitrc
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jay Turner
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-15 08:30 UTC by Marc MERLIN
Modified: 2015-01-07 23:36 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-17 14:52:35 UTC


Attachments (Terms of Use)

Description Marc MERLIN 1999-04-15 08:30:58 UTC
and the same goes for Xresources

Global configuration files never start with a dot, so just
like you have /etc/X11/xinit/Xclients, you should have
Xresources and Xresources (you don't ship those files, but
the xinitrc you ship insists on looking for .Xmodmap
and .Xresources. If you are worried about backward
compatibility, you could be looking for both.

Also, I fail to understand why since the very first versions
of RH, I've always had to create an Xmodmap, or stick
xmodmap -e "keycode  22 = BackSpace" somewhere in the
xinitrc/xsession/wherever.
The problem is so obvious (shows up in vim, any other motif
application like netscape, but not bash), that I can't
believe that you're never seen it yourself. Is there a
reason why you're not fixing this?

Comment 1 Marc MERLIN 1999-06-07 06:12:59 UTC
Ok, I tried with a clean 6.0 install, and the backspace problem is
gone, but only if XkbDisable isn't defined in /etc/X11/XF86config
(which means that it may still be broken for people who upgrade).

While this is fine for American users, people who use high bit ASCII
often end up enabling XkbDisable in order to get accents in some
applications like motif applications
(see http://web.fdn.fr/~tquinot/dead-keys.fr.html for more info, try
babelfish because it's in French unfortunately. It would also be
awesome if you considered incorporating Thomas Quinot's to libX11 that
is described there).

Yeah, I'm not holding my breath, but if I don't ask, I have no chance
of seeing anything happening :-)
(please consider at least sticking that xmodmap -e "keycode  22 =
BackSpace" somewhere so that this problem goes away once and for all)

Comment 2 Preston Brown 1999-06-10 18:40:59 UTC
Marc: I'm on both of these problems, and they should be corrected in
an errata release which will follow shortly.

Comment 3 Bill Nottingham 1999-06-17 14:52:59 UTC
Fixed in errata XFree86-*-52 release.


Note You need to log in before you can comment on or make changes to this bug.