Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 219034 - USB irq routing problems, possibly related to ACPI
Summary: USB irq routing problems, possibly related to ACPI
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 8
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
 
Reported: 2006-12-09 17:49 UTC by Jacob Kroon
Modified: 2008-01-29 22:31 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-29 22:31:54 UTC


Attachments (Terms of Use)
dmesg output (deleted)
2006-12-09 17:51 UTC, Jacob Kroon
no flags Details
dmesg output (deleted)
2006-12-09 17:52 UTC, Jacob Kroon
no flags Details
dmesg output (deleted)
2006-12-09 17:52 UTC, Jacob Kroon
no flags Details
dmesg output (deleted)
2008-01-09 16:07 UTC, Jacob Kroon
no flags Details

Description Jacob Kroon 2006-12-09 17:49:31 UTC
Using kernel-2.6.18-1.2798.fc6
==============================
Using default boot arguments to the kernel,
my wifi ethernet card works, and networking
is ok, but my usb devices refuses to work.
I also see 5 of these warnings being printed
on boot:

ACPI: Unable to set IRQ for PCI Interuppt Link [ALKD] Try pci=noacpi or acpi=off

If I boot with kernel argument "acpi=noirq", those warnings disappear, and usb
devices work ok, but wifi ethernet stops working.

Using kernel-2.6.18-1.2849.fc6
==============================
The scenario is the same as when booting the previous kernel
with acpi=noirq argument. USB devices work, no warnings get printed,
but wifi won't work.

I'm attaching dmesg's reports of the three cases.

Comment 1 Jacob Kroon 2006-12-09 17:51:04 UTC
Created attachment 143221 [details]
dmesg output

Comment 2 Jacob Kroon 2006-12-09 17:52:10 UTC
Created attachment 143222 [details]
dmesg output

Comment 3 Jacob Kroon 2006-12-09 17:52:50 UTC
Created attachment 143223 [details]
dmesg output

Comment 4 Jacob Kroon 2006-12-09 17:55:18 UTC
Forgot to give descriptions of the attachments.

They are in the order listed:

kernel-2.6.18-1.2798.fc6
kernel-2.6.18-1.2798.fc6 + acpi=noirq
kernel-2.6.18-1.2849.fc6


Comment 5 Jacob Kroon 2006-12-19 19:24:52 UTC
Using the newly released kernel-2.6.18-1.2868.fc6 I get
the same behaviour as with 2798. Wifi works out-of-the-box,
but no USB. The same warnings appears in "dmesg", and also
the

ACPI: Unable to set IRQ for PCI Interuppt Link [ALKD] Try pci=noacpi or acpi=off

has re-appeared during boot.


Comment 6 Jon Stanley 2008-01-08 01:55:49 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 7 Jacob Kroon 2008-01-08 07:30:43 UTC
I'm still seeing this bug on Fedora 8. It has been like this for me since Fedora
7 as well, I must be sitting on some rare obscure hardware...

Comment 8 Chuck Ebbert 2008-01-08 21:25:15 UTC
(In reply to comment #7)
> I'm still seeing this bug on Fedora 8. It has been like this for me since Fedora
> 7 as well, I must be sitting on some rare obscure hardware...

Can you post dmesg from the latest kernel booted without any options?

Comment 9 Jacob Kroon 2008-01-09 16:07:42 UTC
Created attachment 291167 [details]
dmesg output

Comment 10 Jacob Kroon 2008-01-09 16:08:51 UTC
Comment #9 is the output of dmesg using kernel-2.6.23.9-85.fc8. (Wifi works, usb
devices don't).

Comment 11 Chuck Ebbert 2008-01-09 18:31:24 UTC
This machine has all kinds of ACPI bugs in its BIOS:

DMI year is 0 (what year was this machine really produced?)
An ACPI region in the EC has no handler.
ACPI BIOS is returning the wrong object type.

We should probably close this as NOTABUG?


Comment 12 Chuck Ebbert 2008-01-29 22:31:54 UTC
System BIOS is flakey, we apparently can't deal with its problems.


Note You need to log in before you can comment on or make changes to this bug.