Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2186 - su - username generates Segmentation fault
Summary: su - username generates Segmentation fault
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-15 03:51 UTC by Jaroslaw Sosnicki
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-04-17 16:29:29 UTC


Attachments (Terms of Use)

Description Jaroslaw Sosnicki 1999-04-15 03:51:17 UTC
When I upgraded from 5.9.8.1 to 5.9.9 I am getting
Segmentation fault when using su - username logged in as
root.
I can do as root: su userid without errors, also I can do
su - userid form other users without errors.

Lookus like a bug to me...

Comment 1 Michael K. Johnson 1999-04-15 15:37:59 UTC
I've fixed a lot of potential segfaults (including some we saw
happen) in the pam_xauth module that is included in pam-0.66-14
and I'm not able to reproduce this, so I will assume that this
is fixed.  If this was happening in X, then I probably fixed it;
if it was happening from the console, then I almost assuredly
fixed it.

If you can reproduce this bug with pam-0.66-14 or later, please
reopen this bug with the version of pam you are using, the version
of sh-utils, and the output of the env command before running the
su - username
Thanks!

Comment 2 Jaroslaw Sosnicki 1999-04-16 22:07:59 UTC
Where do I find pam-0.66-14...

It is not part of 5.9.9

Comment 3 Michael K. Johnson 1999-04-17 16:29:59 UTC
There were two bugs, one hiding the other.  The one was fixed in
0.66-14, the other in 0.66-15.


Note You need to log in before you can comment on or make changes to this bug.