Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 218439 - TB5d4d5b52 config.py:695:_getsysver:StopIteration
Summary: TB5d4d5b52 config.py:695:_getsysver:StopIteration
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 5
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-05 11:37 UTC by Amit Rana
Modified: 2014-01-21 22:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-12-06 16:05:30 UTC


Attachments (Terms of Use)

Description Amit Rana 2006-12-05 11:37:51 UTC
Component: Software Updater
Summary: TB5d4d5b52 config.py:695:_getsysver:StopIteration

Traceback (most recent call last):
  File "/usr/sbin/pup", line 389, in ?
    main()
  File "/usr/sbin/pup", line 382, in main
    pup = PackageUpdater()
  File "/usr/sbin/pup", line 77, in __init__
    GraphicalYumBase.__init__(self, False)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 123, in __init__
    self.doConfigSetup(configfn)
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 102, in
doConfigSetup
    self.conf = config.readMainConfig(fn, root)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 589, in readMainConfig
    vars['releasever'] = _getsysver(earlyconf.installroot, earlyconf.distroverpkg)
  File "/usr/lib/python2.4/site-packages/yum/config.py", line 695, in _getsysver
    hdr = idx.next()
StopIteration

Local variables in innermost frame:
distroverpkg: redhat-release
installroot: /
ts: <rpmUtils.transaction.TransactionWrapper instance at 0xb78f95ac>
idx: <rpm.mi object at 0xb7bb9da0>

Comment 1 Jeremy Katz 2006-12-06 16:05:30 UTC

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.