Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 218436 - booting hangs on uncompressing kernel
Summary: booting hangs on uncompressing kernel
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
 
Reported: 2006-12-05 11:30 UTC by Tomasz Trojanowski
Modified: 2013-01-13 12:29 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-08 04:27:03 UTC


Attachments (Terms of Use)

Description Tomasz Trojanowski 2006-12-05 11:30:11 UTC
On Lenovo 3000 N100 Centrino Duo after upgrade kernel to
2.6.18-1.2849.rc6.i{5,6}86, booting hangs on:

Uncompressing Linux... Ok, booting the kernel

Comment 1 Pierre Gay 2007-03-01 11:10:38 UTC
I have exactly the same problem with a MAXDATA PC.

With kernel 2.6.18-1.2798.fc6 I have to pass "hpet=disable" to boot.

With kernels like 2.6.18-1.2849 and 2.6.19, booting hangs after Ok, booting the
kernel.

Comment 2 Chuck Ebbert 2007-03-01 16:49:06 UTC
(In reply to comment #1)
> I have exactly the same problem with a MAXDATA PC.
> 
> With kernel 2.6.18-1.2798.fc6 I have to pass "hpet=disable" to boot.
> 
> With kernels like 2.6.18-1.2849 and 2.6.19, booting hangs after Ok, booting the
> kernel.

Do you mean "hpet=disable" no longer works?


Comment 3 Pierre Gay 2007-03-01 17:06:27 UTC
I mean that for kernels from 2.6.18-1.2849, boot fails with or without
"hpet=disable".

But hpet may no longer be the principal issue now, because booting hangs just
after "Ok, booting the kernel" and before any other message, even without the
"quiet" argument (2.6.18_1.2798 with "hpet=disable" follows with various PCI
related messages).

Comment 4 Pierre Gay 2007-04-02 15:15:00 UTC
The problem persists with 2.6.20 series (currently 2.6.20-1.2933.fc6).

Comment 5 Chuck Ebbert 2007-04-02 23:20:15 UTC
Try adding

   initcall_debug

to the command line (after "root=<>") for the kernel that hangs and see if it
prints anything.


Comment 6 Pierre Gay 2007-04-03 07:27:40 UTC
I tried booting kernel with comand line:

kernel /vmlinuz-2.6.20-1.2933.fc6 ro root=/dev/VolGroup00/LogVol00
initcall_debug hpet=disable rhgb 

No output after "Ok, booting the kernel." ...


Comment 7 John Ruemker 2007-06-01 05:01:14 UTC
This problem is still existent in F7 (2.6.21-1.3194.fc7), and it seems to be
prevalent on Dell Laptops with Intel Core 2 Duo (from fedoraforum.org).  Normal
boot hangs at "Ok, booting the kernel".  

Removing the quiet option from the grub entry shows more output ending with
"NET: Registering Protocol Family 2" and initcall_debug gives nothing extra. 
Adding "maxcpus=1" kernel option allows the kernel to boot, and others report
"acpi=off" does the same.  

I am running a Dell XPS M1710 with Intel Core 2 Duo 2.0 GHz.    

 

Comment 8 SJM 2007-06-02 05:33:03 UTC
I have the same problem on Fedora 7.
DEll 6400 notebook. It's a Core Dou (note not core 2 duo).
I need to pass maxcpus=1 at boot for it to work -- not ideal.

Didn't happen on Fedora Core 6 but I can't remember which kernel it was running

Comment 9 SJM 2007-06-02 05:35:00 UTC
Looking at the date of the original post I can confirm that in Core 6 i ran
kernels newer than 2.6.18 and it worked fine.

Not in Fedora 7 on the stock kernel that comes with it

Comment 10 John Ruemker 2007-06-10 19:45:09 UTC
Using kernel parameter clocksource=acpi_pm allows successful boot about 75-80%
of the time.  Sometimes it still hangs at uncompressing the kernel, other times
it works fine.   

Comment 11 Jon Stanley 2008-01-08 01:49:11 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 12 Jon Stanley 2008-02-08 04:27:03 UTC
Per the previous comment in this bug, I am closing it as INSUFFICIENT_DATA,
since no information has been lodged for over 30 days.

Please re-open this bug or file a new one if you can provide the requested data,
and thanks for filing the original report!


Note You need to log in before you can comment on or make changes to this bug.