Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2184 - Typo in initscript causes linuxconf to always restart gpm
Summary: Typo in initscript causes linuxconf to always restart gpm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gpm
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
: 2462 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-14 18:19 UTC by Brian Ryner
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-24 14:44:57 UTC


Attachments (Terms of Use)

Description Brian Ryner 1999-04-14 18:19:42 UTC
Whenever I exit linuxconf, it says that it needs to run:

Executing: /etc/rc.d/rc5.d/S85gpm start

gpm is already running--
[root@hh-terrance bryner]# ps ax|grep gpm
  430 ?        S      0:01 gpm -t ps/2

and I haven't made any changes to the mouse configuration.

Comment 1 Brian Ryner 1999-04-29 19:51:59 UTC
This still happens in RH 6.0 final.  If this is important, the mouse
type I selected during installation is "Logitech
FirstMouse+/MouseMan+".

Comment 2 Brian Ryner 1999-05-02 22:13:59 UTC
I found the solution to this.  In /etc/rc.d/init.d/gpm, there is a
typo on line 9:

# pidfile: /var/run/gpmpid

It should have a dot: "/var/run/gpm.pid".  I tested it and verified
that this fixes the problem.

Bug 2462 is also a duplicate of this bug.

Comment 3 Bill Nottingham 1999-05-03 15:44:59 UTC
*** Bug 2462 has been marked as a duplicate of this bug. ***

For some odd reason, my Linuxconf keeps wanting to start gpm
even though it is started already.

I have noticed this behaviour in the Red Hat 5.9 Starbuck
release, after which I did not use any of the Raw Hide
builds, but one of my colleagues has noticed this, who has
used the most recent Raw Hide before we obtained Red Hat 6.0
from FTP and committed it to CD.

Comment 4 Jay Turner 1999-05-24 14:34:59 UTC
This typo is indeed in the 6.0 distribution.

Comment 5 Bill Nottingham 1999-05-24 14:44:59 UTC
fixed in gpm-1.17.5-4, available in Raw Hide


Note You need to log in before you can comment on or make changes to this bug.