Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 217975 - rbash symlink for restricted bash ("bash -r") missing
Summary: rbash symlink for restricted bash ("bash -r") missing
Keywords:
Status: CLOSED DUPLICATE of bug 106493
Alias: None
Product: Fedora
Classification: Fedora
Component: bash
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks: FC7Target
TreeView+ depends on / blocked
 
Reported: 2006-11-30 23:04 UTC by Jason Farrell
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-12-06 17:05:46 UTC


Attachments (Terms of Use)

Description Jason Farrell 2006-11-30 23:04:07 UTC
Description of problem:
The restricted bash shell ("rbash") can only be invoke by "bash -r", since the
"rbash" symlink is missing.

Steps to Reproduce:
1. yum install bash       # if not already installed
2. run "rbash"
  
Actual results:
No such file, since it wasn't provided.

Expected results:
restricted bash shell should work via symlink (by inspecting argv[0] from the
symlink, as is done for egrep and other utils)
1) /bin/rbash symlinked to /bin/bash
2) /bin/rbash added to /etc/shells


Additional info:
manually creating the symlink works:

[root@nano tmp]# rpm -q bash
bash-3.1-16.1
[root@nano tmp]# rpm -ql bash | grep rbash
/usr/share/doc/bash-3.1/rbash.0
/usr/share/doc/bash-3.1/rbash.ps
[root@nano tmp]# whereis rbash
rbash:
[root@nano tmp]# whereis egrep
egrep: /bin/egrep /usr/share/man/man1/egrep.1.gz
[root@nano tmp]# ln -s /bin/bash /bin/rbash
[root@nano tmp]# rbash
[root@nano tmp]# cd /
rbash: cd: restricted

Comment 1 Tim Waugh 2006-12-06 17:05:46 UTC

*** This bug has been marked as a duplicate of 106493 ***


Note You need to log in before you can comment on or make changes to this bug.