Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 217530 - hal/gnome-vfs-mount doesn't see/mount DVD media
Summary: hal/gnome-vfs-mount doesn't see/mount DVD media
Keywords:
Status: CLOSED DUPLICATE of bug 160945
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard: bzcl34nup
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-28 14:30 UTC by Bill Peck
Modified: 2013-03-06 03:48 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-05-07 01:01:26 UTC


Attachments (Terms of Use)

Description Bill Peck 2006-11-28 14:30:08 UTC
Description of problem:
I have two DVD drives, one is a DVDROM and the other is a DVD-RW Drive. The
DVD-RW drive will see blank DVD media fine, but once I burn something or put in
a ragular DVD Video disc it won't show up under Computers://  In fact the DVD-RW
icon will dissapear.

Version-Release number of selected component (if applicable):
FedoraCore 6
[bpeck@bilbo ~]$ rpm -q hal
hal-0.5.8.1-4.fc6
[bpeck@bilbo ~]$ rpm -q gnome-vfs2
gnome-vfs2-2.16.2-1.fc6
[bpeck@bilbo ~]$ rpm -q nautilus
nautilus-2.16.2-5.fc6


How reproducible:
Everytime in the "broken" DVD drive

Steps to Reproduce:
1. Insert blank media and it sees it.
2. Insert burnt DVD media and it doesn't
3. Insert burnt CD media and it sees it.
  
Additional info:

hal-device output of a DVD Video disc which does not show up

[bpeck@bilbo ~]$ hal-device
/org/freedesktop/Hal/devices/volume_part_1_size_8201476096
udi = '/org/freedesktop/Hal/devices/volume_part_1_size_8201476096'
  org.freedesktop.Hal.Device.Volume.method_execpaths = { 'hal-storage-eject' }
(string list)
  org.freedesktop.Hal.Device.Volume.method_argnames = { 'extra_options' }
(string list)
  org.freedesktop.Hal.Device.Volume.method_signatures = { 'as' } (string list)
  org.freedesktop.Hal.Device.Volume.method_names = { 'Eject' } (string list)
  info.interfaces = { 'org.freedesktop.Hal.Device.Volume' } (string list)
  info.udi = '/org/freedesktop/Hal/devices/volume_part_1_size_8201476096'  (string)
  info.product = 'Volume'  (string)
  volume.disc.capacity = 8201476096  (0x1e8d89800)  (uint64)
  volume.disc.is_svcd = false  (bool)
  volume.disc.is_vcd = false  (bool)
  volume.disc.is_videodvd = true  (bool)
  volume.disc.is_rewritable = false  (bool)
  volume.disc.is_appendable = false  (bool)
  volume.disc.is_blank = false  (bool)
  volume.disc.has_data = true  (bool)
  volume.disc.has_audio = false  (bool)
  volume.disc.type = 'dvd_rom'  (string)
  volume.size = 8201476096  (0x1e8d89800)  (uint64)
  volume.num_blocks = 16018508  (0xf46c4c)  (int)
  volume.block_size = 2048  (0x800)  (int)
  info.capabilities = { 'volume.disc', 'volume', 'block' } (string list)
  info.category = 'volume'  (string)
  volume.is_partition = false  (bool)
  volume.is_disc = true  (bool)
  volume.linux.is_device_mapper = false  (bool)
  volume.is_mounted_read_only = false  (bool)
  volume.is_mounted = false  (bool)
  volume.mount_point = ''  (string)
  volume.label = ''  (string)
  volume.uuid = ''  (string)
  volume.fsversion = ''  (string)
  volume.fsusage = ''  (string)
  volume.fstype = ''  (string)
  storage.model = ''  (string)
  block.storage_device =
'/org/freedesktop/Hal/devices/storage_model_DVDRW_IDE_16X'  (string)
  block.is_volume = true  (bool)
  block.minor = 0  (0x0)  (int)
  block.major = 22  (0x16)  (int)
  block.device = '/dev/hdc'  (string)
  linux.hotplug_type = 3  (0x3)  (int)
  info.parent = '/org/freedesktop/Hal/devices/storage_model_DVDRW_IDE_16X'  (string)
  linux.sysfs_path_device = '/sys/block/hdc/fakevolume'  (string)
  linux.sysfs_path = '/sys/block/hdc/fakevolume'  (string)

Here is the output of the Parent DVD device

[bpeck@bilbo ~]$ hal-device /org/freedesktop/Hal/devices/storage_model_DVDRW_IDE_16X
udi = '/org/freedesktop/Hal/devices/storage_model_DVDRW_IDE_16X'
  storage.partitioning_scheme = ''  (string)
  org.freedesktop.Hal.Device.Storage.method_execpaths = { 'hal-storage-eject',
'hal-storage-closetray' } (string list)
  org.freedesktop.Hal.Device.Storage.method_argnames = { 'extra_options',
'extra_options' } (string list)
  org.freedesktop.Hal.Device.Storage.method_signatures = { 'as', 'as' } (string
list)
  org.freedesktop.Hal.Device.Storage.method_names = { 'Eject', 'CloseTray' }
(string list)
  info.interfaces = { 'org.freedesktop.Hal.Device.Storage',
'org.freedesktop.Hal.Device.Storage' } (string list)
  info.addons = { 'hald-addon-storage' } (string list)
  block.storage_device =
'/org/freedesktop/Hal/devices/storage_model_DVDRW_IDE_16X'  (string)
  info.udi = '/org/freedesktop/Hal/devices/storage_model_DVDRW_IDE_16X'  (string)
  storage.removable.media_size = 8201476096  (0x1e8d89800)  (uint64)
  storage.cdrom.write_speeds = { '1385' } (string list)
  storage.cdrom.write_speed = 1385  (0x569)  (int)
  storage.cdrom.read_speed = 11080  (0x2b48)  (int)
  storage.cdrom.support_media_changed = true  (bool)
  storage.cdrom.hddvdrw = false  (bool)
  storage.cdrom.hddvdr = false  (bool)
  storage.cdrom.hddvd = false  (bool)
  storage.cdrom.bdre = false  (bool)
  storage.cdrom.bdr = false  (bool)
  storage.cdrom.bd = false  (bool)
  storage.cdrom.dvdplusrdl = true  (bool)
  storage.cdrom.dvdplusrwdl = false  (bool)
  storage.cdrom.dvdplusrw = true  (bool)
  storage.cdrom.dvdplusr = true  (bool)
  storage.cdrom.dvdram = false  (bool)
  storage.cdrom.dvdrw = true  (bool)
  storage.cdrom.dvdr = true  (bool)
  storage.cdrom.dvd = true  (bool)
  storage.cdrom.cdrw = true  (bool)
  storage.cdrom.cdr = true  (bool)
  storage.requires_eject = true  (bool)
  storage.hotpluggable = false  (bool)
  info.capabilities = { 'storage', 'block', 'storage.cdrom' } (string list)
  info.category = 'storage'  (string)
  info.product = 'DVDRW IDE 16X'  (string)
  storage.size = 0  (0x0)  (uint64)
  storage.removable = true  (bool)
  storage.removable.media_available = true  (bool)
  storage.physical_device = '/org/freedesktop/Hal/devices/pci_1039_5513_ide_1_0'
 (string)
  storage.firmware_version = 'VER_A079'  (string)
  storage.vendor = ''  (string)
  storage.model = 'DVDRW IDE 16X'  (string)
  storage.drive_type = 'cdrom'  (string)
  storage.automount_enabled_hint = true  (bool)
  storage.media_check_enabled = true  (bool)
  storage.no_partitions_hint = true  (bool)
  storage.bus = 'ide'  (string)
  block.is_volume = false  (bool)
  block.minor = 0  (0x0)  (int)
  block.major = 22  (0x16)  (int)
  block.device = '/dev/hdc'  (string)
  linux.hotplug_type = 3  (0x3)  (int)
  info.parent = '/org/freedesktop/Hal/devices/pci_1039_5513_ide_1_0'  (string)
  linux.sysfs_path_device = '/sys/block/hdc'  (string)
  linux.sysfs_path = '/sys/block/hdc'  (string)

here is the output of a burnt CDR

[bpeck@bilbo ~]$ hal-device /org/freedesktop/Hal/devices/volume_label_Fedora_Core
udi = '/org/freedesktop/Hal/devices/volume_label_Fedora_Core'
  volume.unmount.valid_options = { 'lazy' } (string list)
  volume.mount.valid_options = { 'ro', 'sync', 'dirsync', 'noatime',
'nodiratime', 'noexec', 'quiet', 'remount', 'exec', 'utf8', 'uid=', 'mode=',
'iocharset=' } (string list)
  org.freedesktop.Hal.Device.Volume.method_execpaths = { 'hal-storage-mount',
'hal-storage-unmount', 'hal-storage-eject' } (string list)
  org.freedesktop.Hal.Device.Volume.method_argnames = { 'mount_point fstype
extra_options', 'extra_options', 'extra_options' } (string list)
  org.freedesktop.Hal.Device.Volume.method_signatures = { 'ssas', 'as', 'as' }
(string list)
  org.freedesktop.Hal.Device.Volume.method_names = { 'Mount', 'Unmount', 'Eject'
} (string list)
  info.interfaces = { 'org.freedesktop.Hal.Device.Volume' } (string list)
  volume.ignore = false  (bool)
  info.udi = '/org/freedesktop/Hal/devices/volume_label_Fedora_Core'  (string)
  info.product = 'Fedora Core'  (string)
  volume.disc.capacity = 735051776  (0x2bd00000)  (uint64)
  volume.disc.is_svcd = false  (bool)
  volume.disc.is_vcd = false  (bool)
  volume.disc.is_videodvd = false  (bool)
  volume.disc.is_rewritable = false  (bool)
  volume.disc.is_appendable = false  (bool)
  volume.disc.is_blank = false  (bool)
  volume.disc.has_data = true  (bool)
  volume.disc.has_audio = false  (bool)
  volume.disc.type = 'cd_r'  (string)
  volume.size = 7000064  (0x6ad000)  (uint64)
  volume.num_blocks = 13672  (0x3568)  (int)
  volume.block_size = 2048  (0x800)  (int)
  info.capabilities = { 'volume.disc', 'volume', 'block' } (string list)
  info.category = 'volume'  (string)
  volume.is_partition = false  (bool)
  volume.is_disc = true  (bool)
  volume.linux.is_device_mapper = false  (bool)
  volume.is_mounted_read_only = true  (bool)
  volume.is_mounted = true  (bool)
  volume.mount_point = '/media/Fedora Core'  (string)
  volume.label = 'Fedora Core'  (string)
  volume.uuid = ''  (string)
  volume.fsversion = ''  (string)
  volume.fsusage = 'filesystem'  (string)
  volume.fstype = 'iso9660'  (string)
  storage.model = ''  (string)
  block.storage_device =
'/org/freedesktop/Hal/devices/storage_model_DVDRW_IDE_16X'  (string)
  block.is_volume = true  (bool)
  block.minor = 0  (0x0)  (int)
  block.major = 22  (0x16)  (int)
  block.device = '/dev/hdc'  (string)
  linux.hotplug_type = 3  (0x3)  (int)
  info.parent = '/org/freedesktop/Hal/devices/storage_model_DVDRW_IDE_16X'  (string)
  linux.sysfs_path_device = '/sys/block/hdc/fakevolume'  (string)
  linux.sysfs_path = '/sys/block/hdc/fakevolume'  (string)

Comment 1 Bug Zapper 2008-04-03 18:43:15 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

Comment 2 Bug Zapper 2008-05-07 01:01:24 UTC
This bug has been in NEEDINFO for more than 30 days since feedback was
first requested. As a result we are closing it.

If you can reproduce this bug in the future against a maintained Fedora
version please feel free to reopen it against that version.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

Comment 3 Axel Thimm 2009-05-24 07:37:04 UTC

*** This bug has been marked as a duplicate of bug 160945 ***


Note You need to log in before you can comment on or make changes to this bug.