Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 217227 - URL problem in local DVD repository
Summary: URL problem in local DVD repository
Keywords:
Status: CLOSED DUPLICATE of bug 212180
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-25 10:24 UTC by Tamal Kanti Nath
Modified: 2014-01-21 22:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-27 22:45:15 UTC


Attachments (Terms of Use)
My custom offline DVD repository (deleted)
2006-11-25 10:24 UTC, Tamal Kanti Nath
no flags Details

Description Tamal Kanti Nath 2006-11-25 10:24:32 UTC
Description of problem:
I want to add some packages from my DVD and not from "core" repository. For
this, I had disabled the core repository and created my own repository,
dvd.repo. Here I have set
baseurl=file:///media/FC_6 i386 DVD
bit it didn't work. Possibly because the auto-mounted DVD has its name its
space. The error was:
Options Error: Error parsing 'file:///media/FC_6 i386 DVD': URL must be http,
ftp, file or https not ""
Then I made a soft link:
ln -s "/media/FC_6 i386 DVD" /mnt/fedora
And again edited dvd.repo:
baseurl=file:///mnt/fedora
This time the error was:
media://1161131669.029329%233/Fedora/RPMS/emacs-21.4-17.i386.rpm: [Errno 4]
IOError: <urlopen error unknown url type: media>
Trying other mirror.
Error: failed to retrieve Fedora/RPMS/emacs-21.4-17.i386.rpm from dvd
error was [Errno 4] IOError: <urlopen error unknown url type: media>

Version-Release number of selected component (if applicable):
yum-3.0.1-2.fc6
hal-0.5.8.1-4.fc6
autofs-5.0.1-0.rc2.22

Expected results:
As FC6 DVD contain core files, my dvd repository should be used for core files.

Comment 1 Tamal Kanti Nath 2006-11-25 10:24:32 UTC
Created attachment 142107 [details]
My custom offline DVD repository

Comment 2 Jeremy Katz 2006-11-27 22:45:15 UTC

*** This bug has been marked as a duplicate of 212180 ***


Note You need to log in before you can comment on or make changes to this bug.