Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2167 - Xconfigurator fails to start X server
Summary: Xconfigurator fails to start X server
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: Xconfigurator
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 3211 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-13 13:58 UTC by Chris Runge
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-21 15:14:07 UTC


Attachments (Terms of Use)

Description Chris Runge 1999-04-13 13:58:46 UTC
I'm using the latest 5.9.7 release (3.1?) from gribble.
Xconfigurator fails to start the X server after the video
card, monitor, and default resolution/color depth are
selected.  I have this problem with both an ATI Rage Pro
(AGP) board and Matrox Millenium board.  In addition, the
default color depth and resolution are no longer auto-probed
for the Matrox (this used to work fine in 5.2 and before).

Comment 1 Dale Lovelace 1999-06-04 20:09:59 UTC
Did 6.0 final clear this up?

------- Email Received From  "Chris Runge" <crunge@mindspring.com> 06/05/99 06:37 -------

Comment 2 Cristian Gafton 1999-06-18 16:41:59 UTC
It works for me, but maybe preston has a clue.

Comment 3 Preston Brown 1999-06-21 15:14:59 UTC
There are problems probing for the amount of memory on many
milleniums, so the card has been "blacklisted" for probing until a
better solution can be found.  This is why it doesn't determine which
resolutions are available-- it doesn't know how much ram is on the
card.

Xconfigurator will be receiving a complete overhaul for the next
release, and this will be addressed.

Comment 4 Preston Brown 1999-06-21 16:02:59 UTC
*** Bug 3211 has been marked as a duplicate of this bug. ***

The latest version of Xconfigurator is unable to correctly
probe my Matrox Millenium II PCI (8MB) video card. The card
is identified properly, but probing for possible resolutions
and color depths fails. I'm forced to enter information
manually. Xconfigurator worked properly with this card with
RH5.2. Video performance seems to be diminished with this
version of Xconfigurator.


Note You need to log in before you can comment on or make changes to this bug.