Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 216642 - Problem with "rpmbuild -ta"
Summary: Problem with "rpmbuild -ta"
Keywords:
Status: CLOSED DUPLICATE of bug 206841
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 5
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-21 10:25 UTC by Stephen Quinney
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-21 10:51:07 UTC


Attachments (Terms of Use)
tarball I was attempting to build (deleted)
2006-11-21 10:25 UTC, Stephen Quinney
no flags Details

Description Stephen Quinney 2006-11-21 10:25:53 UTC
Description of problem:

Using "rpmbuild -ta" on x86_64 does not seem to work correctly, where it does on
i386. This is with rpm version 4.4.2-15.2

Here's the error:

$ rpmbuild  -ta kdcregister-1.9.tar.gz
error: Name field must be present in package: (main package)
error: Version field must be present in package: (main package)
error: Release field must be present in package: (main package)
error: Summary field must be present in package: (main package)
error: Group field must be present in package: (main package)
error: License field must be present in package: (main package)

Here's the same tarball on i386:

rpmbuild  -ta kdcregister-1.9.tar.gz
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.72832
+ umask 022
+ cd /afs/inf.ed.ac.uk/user/s/squinney/rpmbuild/BUILD
+ LANG=C
+ export LANG
+ unset DISPLAY
+ cd /afs/inf.ed.ac.uk/user/s/squinney/rpmbuild/BUILD
+ rm -rf kdcregister
+ /bin/gzip -dc /afs/inf.ed.ac.uk/user/s/squinney/dice/kdcregister-1.9.tar.gz
+ tar -xf -
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd kdcregister
++ /usr/bin/id -u
+ '[' 335781 = 0 ']'
++ /usr/bin/id -u
+ '[' 335781 = 0 ']'
+ /bin/chmod -Rf a+rX,u+w,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.72832
+ umask 022
+ cd /afs/inf.ed.ac.uk/user/s/squinney/rpmbuild/BUILD
+ cd kdcregister
+ LANG=C
+ export LANG
+ unset DISPLAY
+ make
cc -I/usr/kerberos/include -I/usr/include/krb5/ -I/usr/include/kadm
-I/usr/include/et -Wall   -c -o kdcregister.o kdcregister.c
gcc -o kdcregister kdcregister.o -L/usr/kerberos/lib -lkadm5clnt -lgssrpc
-lgssapi_krb5 -lkrb5 -lk5crypto -lcom_err
+ exit 0
Executing(%install): /bin/sh -e /var/tmp/rpm-tmp.72832
+ umask 022
+ cd /afs/inf.ed.ac.uk/user/s/squinney/rpmbuild/BUILD
+ cd kdcregister
+ LANG=C
+ export LANG
+ unset DISPLAY
+ make DESTDIR=/var/tmp/kdcregister-1.9 install
mkdir -p /var/tmp/kdcregister-1.9/usr/bin/
mkdir -p /var/tmp/kdcregister-1.9/usr/man/man1
install -s -m 755 kdcregister /var/tmp/kdcregister-1.9/usr/bin/kdcregister
install    -m 644 kdcregister.M /var/tmp/kdcregister-1.9/usr/man/man1/kdcregister.1
+ /usr/lib/rpm/brp-compress
+ find /var/tmp/kdcregister-1.9/usr -type f -print
+ sed 's@^/var/tmp/kdcregister-1.9@@g'
+ /usr/lib/rpm/find-debuginfo.sh
/afs/inf.ed.ac.uk/user/s/squinney/rpmbuild/BUILD/kdcregister
0 blocks
find: /var/tmp/kdcregister-1.9/usr/lib: No such file or directory
+ /usr/lib/rpm/check-rpaths /usr/lib/rpm/check-buildroot
+ /usr/lib/rpm/redhat/brp-compress
+ /usr/lib/rpm/redhat/brp-strip-static-archive /usr/bin/strip
+ /usr/lib/rpm/redhat/brp-strip-comment-note /usr/bin/strip /usr/bin/objdump
+ /usr/lib/rpm/brp-python-bytecompile
Processing files: kdcregister-1.9-1
Requires(rpmlib): rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
Requires: libc.so.6 libc.so.6(GLIBC_2.0) libcom_err.so.2 libgssapi_krb5.so.2
libgssrpc.so.4 libk5crypto.so.3 libkadm5clnt.so.5
libkadm5clnt.so.5(kadm5clnt_5_MIT) libkrb5.so.3 libkrb5.so.3(krb5_3_MIT)
Processing files: kdcregister-debuginfo-1.9-1
Checking for unpackaged file(s): /usr/lib/rpm/check-files /var/tmp/kdcregister-1.9
Wrote: /afs/inf.ed.ac.uk/user/s/squinney/rpmbuild/SRPMS/kdcregister-1.9-1.src.rpm
Wrote:
/afs/inf.ed.ac.uk/user/s/squinney/rpmbuild/RPMS/i386/kdcregister-1.9-1.i386.rpm
Wrote:
/afs/inf.ed.ac.uk/user/s/squinney/rpmbuild/RPMS/i386/kdcregister-debuginfo-1.9-1.i386.rpm
Executing(%clean): /bin/sh -e /var/tmp/rpm-tmp.76399
+ umask 022
+ cd /afs/inf.ed.ac.uk/user/s/squinney/rpmbuild/BUILD
+ cd kdcregister
+ rm -rf /var/tmp/kdcregister-1.9
+ exit 0

I've attached the tarball in case it is actually caused by something I've
done wrong.

Cheers,

Stephen Quinney

Comment 1 Stephen Quinney 2006-11-21 10:25:53 UTC
Created attachment 141749 [details]
tarball I was attempting to build

Comment 2 Paul Nasrat 2006-11-21 10:39:27 UTC
What version of tar do you have on the x86_64 box (rpm -q tar).

Comment 3 Stephen Quinney 2006-11-21 10:44:52 UTC
On the x86_64 box I had tar-1.15.91-1.FC5 and on the i386 box I have
tar-1.15.1-16.FC5. I have just used yum to upgrade the tar version on my x86_64
box to tar-1.15.1-16.FC5 and it all works now. Sorry for bothering you, I should
have thought of checking for relevant updates first.

Thanks,

Stephen Quinney


Comment 4 Paul Nasrat 2006-11-21 10:51:07 UTC

*** This bug has been marked as a duplicate of 206841 ***


Note You need to log in before you can comment on or make changes to this bug.