Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 216528 - vesa framebuffer (vga=0x317) parameter blanks display
Summary: vesa framebuffer (vga=0x317) parameter blanks display
Keywords:
Status: CLOSED DUPLICATE of bug 236195
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Don Zickus
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-20 22:51 UTC by Erik Bussink
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-26 16:09:17 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Erik Bussink 2006-11-20 22:51:42 UTC
Description of problem:

If the vga=0x317 kernel boot parameter is present, there is no text display.
The screen stays blank, while the system starts up in the background. 

Version-Release number of selected component (if applicable):

This is the sample section taken from my grub.conf that shows the vga=0x317

title Red Hat Enterprise Linux Client (2.6.18-1.2747.el5)
        root (hd0,1)
        kernel /vmlinuz-2.6.18-1.2747.el5 ro root=LABEL=/ rhgb quiet vga=0x317
        initrd /initrd-2.6.18-1.2747.el5.img

How reproducible:

If the vga=0x317 boot parameter is present, no graphical display. If it's
removed, the boot process is visible at normal text resolution.

Steps to Reproduce:
1. add vga=03x17 to kernel parameters.
2. reboot
3. Connect to system with SSH and edit grub.conf to remove kernel parameter.
  
Actual results:

Blanks text display

Expected results:

The utilisation of the vga= goes on kernel line and controls the resolution and
colour depth of framebuffer, which should load 128x48 (or 1024x768 pixel)
resolution instead of the default 80x24.

vesafb codes

    | 640x480  800x600  1024x768 1280x1024
----+-------------------------------------
256 |  0x301    0x303    0x305    0x307   
32k |  0x310    0x313    0x316    0x319   
64k |  0x311    0x314    0x317    0x31A   
16M |  0x312    0x315    0x318    0x31B

Additional info:

/usr/share/doc/kernel-doc-2.6.18/Documentation/fb/vesafb.txt

Comment 4 RHEL Product and Program Management 2007-04-25 23:05:51 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 5 Peter Martuccelli 2007-04-26 16:09:17 UTC

*** This bug has been marked as a duplicate of 236195 ***


Note You need to log in before you can comment on or make changes to this bug.