Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 216460 - r8169 does not work after reboot, but works after power down
Summary: r8169 does not work after reboot, but works after power down
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
 
Reported: 2006-11-20 16:56 UTC by Kevin DeKorte
Modified: 2008-02-08 04:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-08 04:29:00 UTC


Attachments (Terms of Use)

Description Kevin DeKorte 2006-11-20 16:56:26 UTC
Description of problem:
Using FC6, and several kernels including 2.6.18-1.2849.fc6. If I reboot my
machine, the r8169 driver does not load properly and you can't make a network
connection. Powering off the machine, waiting 10-15secs and then powering up,
the controller works properly.

Version-Release number of selected component (if applicable):
2.6.18-1.2849.fc6

How reproducible:
100%

Steps to Reproduce:
1. Cold boot, make connection with card
2. reboot
3. card is not loaded and ifconfig sees it with a name like _tmp23453467
  
Actual results:
Can't connect using TCP/IP after warm boot

Expected results:
Connection should work after cold or warm boot

Additional info:

Comment 1 storno 2007-07-07 05:36:14 UTC
I've run into this bug on Fedora 7 using the following two kernels:

2.6.21-1.3194-fc7
GOLD 2.6.21-1.3228-fc7

Upon soft-boot, the device appears to fail establishing an Ethernet link, dmesg
reports the following:

ADDRCONF(NETDEV_UP): eth0: link is not ready

Upon cold-boot, device links fine, but I was still unable to push any traffic
through (perhaps a misconfig on my part).

Comment 2 Kevin DeKorte 2007-08-29 16:57:56 UTC
I believe this is fixed in 2.6.22.4-65.fc7 and possibly in kernel-2.6.22.1-41.fc7

Comment 3 Kevac Marko 2007-11-11 19:48:17 UTC
It is still not fixed.

$ cat /etc/fedora-release 
Fedora release 8 (Werewolf)

$ uname -a
Linux localhost.localdomain 2.6.23.1-42.fc8 #1 SMP Tue Oct 30 13:55:12 EDT 2007
i686 i686 i386 GNU/Linux

$ dmesg | egrep "eth0|r8169"
r8169 Gigabit Ethernet driver 2.2LK-NAPI loaded
eth0: RTL8169sc/8110sc at 0xf8828000, 00:1a:4d:73:5f:2e, XID 18000000 IRQ 20
r8169: eth0: link down
r8169: eth0: link down
ADDRCONF(NETDEV_UP): eth0: link is not ready

I have tried to power off machine. But this didn't helped.

Comment 4 Jon Stanley 2008-01-08 01:50:52 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 5 Jon Stanley 2008-02-08 04:29:00 UTC
Per the previous comment in this bug, I am closing it as INSUFFICIENT_DATA,
since no information has been lodged for over 30 days.

Please re-open this bug or file a new one if you can provide the requested data,
and thanks for filing the original report!


Note You need to log in before you can comment on or make changes to this bug.