Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 216312 - Summary: kernel Oops when mounting CD-ROM as user
Summary: Summary: kernel Oops when mounting CD-ROM as user
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: x86_64
OS: Linux
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
Reported: 2006-11-19 04:42 UTC by Trevin Beattie
Modified: 2008-01-10 02:37 UTC (History)
2 users (show)

Fixed In Version: 2.6.18-1.2850
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-01-10 02:37:56 UTC

Attachments (Terms of Use)

Description Trevin Beattie 2006-11-19 04:42:54 UTC
Description of problem:
I just added a couple of lines to my /etc/fstab file in order to let me manually
mount CD's without having to switch to root:

/dev/hda                /mnt/cdrom1             autofs  noauto,user,ro  0 0
/dev/hdb                /mnt/cdrom2             autofs  noauto,user,ro  0 0

The trouble is that when I try to "mount /mnt/cdrom1" (using a FC6 SRPM CD), the
computer locks up.  I can ping it from another machine, but there is no response
from the console, and I can't ssh in.

The first time this happened I didn't see anything in the system log to indicate
what the problem was.  The second time I found the following message:

ov 18 19:53:00 hydra kernel: autofs: called with bogus options
Nov 18 19:53:00 hydra kernel: Unable to handle kernel NULL pointer dereference
at 0000000000000070 RIP: 
Nov 18 19:53:00 hydra kernel:  [<ffffffff88626793>]
Nov 18 19:53:00 hydra kernel: PGD 6fad9067 PUD 6e487067 PMD 0 
Nov 18 19:53:00 hydra kernel: Oops: 0000 [1] SMP 

First, I don't understand what autofs is complaining about.  I double-checked
the mount(8) man page, and noauto, user, and ro are all valid options.

Second, even if I did have bad options in /etc/fstab I don't think that should
cause a kernel crash!

Version-Release number of selected component (if applicable):

How reproducible:
Three crashes out of three attempts.  Previously I had been letting nautilus
auto-mount the drives, and most of the time it worked fine, though sometimes it
simply did nothing.  In the latter case I'd have to mount the drive manually, as
root, using "mount -o ro /dev/hda /mnt/cdrom1", and that worked too.  I can
still manually mount the disc as root.

Steps to Reproduce:
1. Add a line to /etc/fstab to mount a CD with the "noauto,user,ro" options and
"autofs" file system.
2. Switch to normal user mode.
3. mount /mnt/cdrom
Actual results:
Oops: 0000 [1] SMP

Expected results:
Should have mounted the disc.

Additional info:

Comment 1 Trevin Beattie 2006-11-22 04:45:24 UTC
Sorry, I just noticed that kernel version was a typo.  It should say:

Comment 2 Jon Stanley 2008-01-08 01:48:53 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)


I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

I am CC'ing myself to this bug, however this version of Fedora is no longer

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 3 Trevin Beattie 2008-01-10 02:37:56 UTC
A few weeks after filing this bug I had upgraded the kernel to 2.6.18-1.2850. 
Last September I upgraded to  I don't recall seeing any more
Oopses in all that time.

Note You need to log in before you can comment on or make changes to this bug.