Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 216041 - IDE/SATA modules should be built into the kernel
Summary: IDE/SATA modules should be built into the kernel
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks: 427887
TreeView+ depends on / blocked
 
Reported: 2006-11-16 21:52 UTC by Deepak Bhole
Modified: 2008-01-08 15:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-01-08 15:01:01 UTC


Attachments (Terms of Use)

Description Deepak Bhole 2006-11-16 21:52:19 UTC
Description of problem:
IDE/SATA modules are critical, and should be built into the kernel.

Version-Release number of selected component (if applicable):
2.6.18-1.2798.fc6

How reproducible:
Always

Steps to Reproduce:
The steps require the appropriate hardware combination. In my case:
Asus A8V board (KT800 Pro)
Promise SATA300 TX2Plus sata card (PDC40775 rev 02)
Seagate ST3320620AS (320.0 GB, SATA) drive

If the Seagate drive attached to the SATA card is the main drive, the kernel
cannot boot as it fails to load the root drive and panics.

Actual results:
Kernel Panic

Expected results:
Kernel should boot

Additional info:
I had the same issue with the vanilla 2.6.18.1 kernel, but was able to get the
system booted after I recompiled the kernel with the sata_promise driver
"built-in", as opposed to a module.

SATA/IDE drivers are critical as they need to be loaded as early during boot as
possible. If the driver is present as a module, in some cases it seems that the
kernel cannot detect it early enough.

Comment 1 Jon Stanley 2008-01-08 01:47:42 UTC
(This is a mass-update to all current FC6 kernel bugs in NEW state)

Hello,

I'm reviewing this bug list as part of the kernel bug triage project, an attempt
to isolate current bugs in the Fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

I am CC'ing myself to this bug, however this version of Fedora is no longer
maintained.

Please attempt to reproduce this bug with a current version of Fedora (presently
Fedora 8). If the bug no longer exists, please close the bug or I'll do so in a
few days if there is no further information lodged.

Thanks for using Fedora!

Comment 2 Deepak Bhole 2008-01-08 15:01:01 UTC
I no longer use the setup with which I encountered this bug. Since I have not
encountered the issue with other setups, I am closing this as WORKSFORME.


Note You need to log in before you can comment on or make changes to this bug.