Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 215901 - yum crash/freeze very often
Summary: yum crash/freeze very often
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 5
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-16 10:04 UTC by Frank Büttner
Modified: 2014-01-21 22:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-07-17 12:04:28 UTC


Attachments (Terms of Use)

Description Frank Büttner 2006-11-16 10:04:30 UTC
Description of problem:
When call yum update it often crash with segfault or it hangs at this point:
Loading "installonlyn" plugin
Setting up Update Process
Setting up repositories
updates                                                        [2/4]
updates             100% |=========================|  951 B    00:00
core                                                           [3/4]
core                100% |=========================| 1.3 kB    00:00
extras                                                               [4/4]
extras                    100% |=========================| 1.1 kB    00:00
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 355 kB    00:00
updates: ################################################## 916/916
Added 46 new packages, deleted 1 old in 4.61 seconds
here it hangs:(

Version-Release number of selected component (if applicable):
yum-2.6.1-0.fc5

How reproducible:
when you call it 10 times it will crash/hang 2 times

Steps to Reproduce:
1. run yum update
 
Actual results:
often crash/hang

Expected results:
clean running

Additional info:
To get it working after an crash/haning I must delete the files /var/lib/rpm/db*

Comment 1 Ra P. 2006-11-16 19:36:26 UTC
I have the EXACT  same problem, it hangs at the exact same place..
Does the same thing with smart update. I tried rebuilding the db, removing those
files, they solve it for once, so I can run yum *once* and then second time I
run it, it goes back to the beginning (freezes again)

Comment 2 Frank Büttner 2006-11-16 19:45:04 UTC
I have tested it with an second FC5 system.(clean setup) But after apply all
updates the same. Without the updates all is ok. I think an update is buggy. 

Comment 3 Kasper Dupont 2006-11-23 07:19:36 UTC
I think this might be a duplicate of bug #203233

Comment 4 Jeff Johnson 2006-12-03 18:32:31 UTC
Segafualts and loss of data are likely due to removing an rpmdb environment
without correcting other problems in the rpmdb.

FYI: Most rpmdb "hangs" are now definitely fixed by purging stale read locks when opening
a database environment in rpm-4.4.8-0.4. There's more todo, but I'm quite sure that a
large class of problems with symptoms of "hang" are now corrected.

Detecting damaged by verifying when needed is well automated in rpm-4.4.8-0.4. Automatically 
correcting all possible damage is going to take more work, but a large class of problems is likely
already fixed in rpm-4.4.8-0.4 as well.

UPSTREAM

Comment 5 Pavel Rosenboim 2006-12-18 08:32:50 UTC
Same here. In FC6 and in FC5 after some upgrade rpm became very unstable - I
have lots of hangs and crashes in all rpm-related tools.

Comment 6 Panu Matilainen 2007-07-17 12:04:28 UTC

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.