Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 215016 - ata-piix failure on ICH6
Summary: ata-piix failure on ICH6
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: All
OS: Linux
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
Whiteboard: bzcl34nup
Depends On:
Blocks: FC7Target FCMETA_SATA
TreeView+ depends on / blocked
Reported: 2006-11-10 16:57 UTC by
Modified: 2013-07-03 02:30 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2008-10-21 08:13:17 UTC

Attachments (Terms of Use)
Anaconda Crash dump from f7t3 (deleted)
2007-03-29 20:30 UTC,
no flags Details
lspci -n (deleted)
2007-04-19 19:23 UTC,
no flags Details

Description 2006-11-10 16:57:48 UTC
Description of problem:

FC6 does not find the harddisk, fc6test3 does find the harddisk.

fc6 does load ata_piix which does not work, fc6test3 loads the correct
ahci-module and therefore detects the harddrive.

System is a Toshiba Tecra S3 laptop with a sata-harddisk and intel-chipset. 

Version-Release number of selected component (if applicable):

How reproducible:

Every time.

Steps to Reproduce:
1. Try to instal fc6 release
Actual results:

Expected results:

Additional info:

Comment 1 2007-02-08 16:36:00 UTC
Not fixed in fc7test1.

Comment 2 2007-03-02 05:36:50 UTC
Not fixed in f7test2.

Comment 3 2007-03-29 20:30:00 UTC
Created attachment 151234 [details]
Anaconda Crash dump from f7t3

I tried to instal f7test3. Anaconda crashes while searching for existing
fedora installations. It dumps a debug-log into the dialog and asks to report a
bug against anaconda. I'm quite sure it'y my long-time-bug 215016 as anaconda
does not see the harddisk.

Comment 4 2007-03-30 17:06:25 UTC
If I boot f7t3 install dvd with kernel parameter noprobe, the problem can be fixed.

When manually selecting the drivers, the driver ahci has to be loaded first,
that brings up the harddisk. Second the driver ata_piix has to be loaded, to get
access to the optival drive.

Perhaps it`s an anaconda and no kernel bug ?

Comment 5 2007-04-09 20:50:06 UTC
Tested on 2007-04-09s Rawhide. Loading the wrong drivers by Anaconda can be
fixed by starting with noprobe and loading the drivers manually. Sadly the
installed systems does not boot and crahes while starting.

Comment 6 2007-04-17 15:50:11 UTC
No changes in 2007-04-17 rawhide.

Comment 7 Dave Jones 2007-04-19 19:08:33 UTC
can you attach the lspci -n output please?

Comment 8 2007-04-19 19:23:40 UTC
Created attachment 153050 [details]
lspci -n

sure, comes at once.

Comment 9 2007-04-23 18:05:29 UTC
Ubuntu 7 has similar problems.

Comment 10 Dave Jones 2007-04-23 20:03:55 UTC
*** Bug 231273 has been marked as a duplicate of this bug. ***

Comment 11 2007-04-27 13:45:44 UTC
Tested f4t3 because of kernel 2.6.21 but no change.

Comment 12 2007-05-14 18:28:34 UTC
no change with kernel 3142

Comment 13 Jeremy Katz 2007-05-18 15:50:30 UTC
Given the presence of a workaround, moving to target.

Comment 14 2007-05-18 15:53:31 UTC
Which workaround ?

Comment 15 2007-05-22 19:36:06 UTC
I just tried to install todays rawhide via pxe. The bug is not fixed.
Anaconda does not see the harddisk.

Booting with noprobe and manually loading ahci and ata_piix (order
matters) gets the harddisk online but installs a non-bootable system.

Comment 16 Bradley 2007-06-01 07:51:40 UTC
This bit me upgrading to F7. I managed to install FC6 by changing VTs and doing
rmmod ata_piix/insmod ahci, but under F7 something's holding a reference to the
DVD drive, so I can't rmmod ata_piix.

This is on a Toshiba Tecra S3, with no BIOS option to enable/disable AHCI. I
haven't tried noprobe as an option yet.

Unlike comment #4, I don't have to load ata_piix; ahci works for both drives.

Comment 17 Bradley 2007-06-02 01:03:39 UTC
Actually, I do have to load ata_piix, but noprobe worked for me.

Comment 18 Mihai Harpau 2007-06-08 20:29:05 UTC
I could install F7 on a Toshiba Tecra S3 130 by booting with noprobe and
manually loading ahci first and ata_piix second. 

After that system work without problems.

Comment 19 2007-06-15 17:54:17 UTC
Still there in F7 release and Rawhide 2007-06-15.

Comment #18 -> comment #5 still applies to my machine.

Comment 20 2007-07-24 20:58:19 UTC
Still there in rawhide-2007-07-24.

Comment 21 2007-08-13 19:45:15 UTC
Still there in F8Test1.

Comment 22 2007-09-15 12:38:13 UTC
Still there in F8Test2.

Comment 23 2007-09-15 12:42:11 UTC
Tejun Heo from Kernel-Bugzilla says, it`s a distribution-error due to wrong
module loading order.

I tested F8test2 with noprobe and manually loaded the modules. The installation
works, but produces a non booting system.

Comment 24 Bill Nottingham 2007-09-17 18:00:19 UTC
Tejun is wrong.

Module loading is non-deterministic, thanks to the kernel-mandated use of udev.
If drivers cannot cope with this, they are broken.

Comment 25 2007-09-17 18:10:35 UTC
Thanks for your comment. I reopened the bug in

cu romal

Comment 26 2007-09-19 05:51:46 UTC

------- Comment #17 from  2007-09-18 21:48 -------
The controller has two interfaces - compatible IDE interface and an AHCI one. 
The IDE interface can be driven by ata_piix while the AHCI interface can be
driven by ahci.  If ata_piix is loaded first, it grabs the device; otherwise,

This is a special case.  IIRC, in all other cases, dual mode controllers can be
put into one of either mode and that is determined either by BIOS or PCI
quirks, so no driver contention there.  Only ICH6s use the same PCI ID for both
IDE and AHCI modes and those two drivers differ in capability.

Drivers are coping quite well but they can't cope beyond hardware restrictions.
 One solution I can think of is to conditionalize out those duplicate PCI IDs
>from ata_piix if CONFIG_SATA_AHCI is 'y' or 'm' but I'm afraid that would just
end up upsetting more users.  Things have been this way for a very long time

Distros can comment out duplicate PCI IDs from ata_piix if making module
loading order deterministic is difficult.

Robert, can you cc Bill Nottingham here?

Comment 27 2007-11-12 08:01:12 UTC
It is in F8 as well.

Comment 28 Bug Zapper 2008-04-03 18:36:30 UTC
Based on the date this bug was created, it appears to have been reported
against rawhide during the development of a Fedora release that is no
longer maintained. In order to refocus our efforts as a project we are
flagging all of the open bugs for releases which are no longer
maintained. If this bug remains in NEEDINFO thirty (30) days from now,
we will automatically close it.

If you can reproduce this bug in a maintained Fedora version (7, 8, or
rawhide), please change this bug to the respective version and change
the status to ASSIGNED. (If you're unable to change the bug's version
or status, add a comment to the bug and someone will change it for you.)

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we're following is outlined here:

We will be following the process here: to ensure this
doesn't happen again.

Comment 29 2008-04-16 12:38:22 UTC
Jeff Garzik upstreamed a fix on 04.04.2008 into the kernel. With the
installation-media based on a rebased kernel.rpm I call test, if the fix works.

With Fedora 9 Beta the ich6-driver is still broken.

Comment 30 2008-04-18 16:21:21 UTC
Still broken in F9 preview. Anaconda does not see any hdds.

Comment 31 Chuck Ebbert 2008-04-18 18:56:07 UTC
The kernel in the preview was built on April 10 and should have the fix
mentioned in comment 29.

Comment 32 2008-04-20 07:50:29 UTC
Maybe Jeff can answers this. Is this patch included in 2.6.25 oder scheduled for
a later kernel ?

Posted by Tejun:
Included by Jeff:

Comment 33 2008-04-23 18:16:31 UTC
Still broken in F9 Preview.

Comment 35 Bill Nottingham 2008-04-24 03:27:40 UTC
Booting the installer with 'blacklist=ata_piix' may help you.

Comment 36 2008-04-24 04:46:21 UTC
The optical drives depends on ata_piix.

Comment 37 Bill Nottingham 2008-04-24 14:11:37 UTC
Doh. So, what you'd have to do is to boot with 'blacklist=ata_piix', and then go
to driver selection and try and load the driver later after ahci loads.

Comment 38 2008-04-25 13:13:55 UTC
Yes, that works. I always booted via pxe and did a network-install.

Comment 39 Bug Zapper 2008-05-14 02:27:58 UTC
Changing version to '9' as part of upcoming Fedora 9 GA.
More information and reason for this action is here:

Comment 40 2008-10-21 08:12:58 UTC
Fixed in F10 Snap 2 due to kernel 2.6.27. Thanks to all.

Note You need to log in before you can comment on or make changes to this bug.