Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 214587 - 'look a' shows nothing
Summary: 'look a' shows nothing
Keywords:
Status: CLOSED DUPLICATE of bug 153276
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: util-linux
Version: 4.4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-08 15:07 UTC by Shing-Shong Shei
Modified: 2007-11-17 01:14 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-12-02 18:21:06 UTC


Attachments (Terms of Use)

Description Shing-Shong Shei 2006-11-08 15:07:23 UTC
Description of problem:


Version-Release number of selected component (if applicable):
2.12a-16.EL4.20

How reproducible:
Every time

Steps to Reproduce:
1. look a
2.
3.
  
Actual results:
Nothing

Expected results:
All words in the dictionary starting with a.

Additional info:

'strace -fv look a' shows that it quits after:

8030  open("/usr/share/dict/words", O_RDONLY|O_LARGEFILE) = 3
8030  fstat64(3, {st_dev=makedev(8, 3), st_ino=3499728, st_mode=S_IFREG|0644,
st_nlink=1, st_uid=0, st_gid=0, st_blksize=4096, st_blocks=9784, st_size=4992010,
st_atime=2006/11/08-09:52:46, st_mtime=2004/11/08-16:33:07,
st_ctime=2006/10/04-10:02:02}) = 0
8030  mmap2(NULL, 4992010, PROT_READ, MAP_SHARED, 3, 0) = 0xb787b000
8030  exit_group(1)

while if you do 'strace -fv look b' it goes much further:

8037  open("/usr/share/dict/words", O_RDONLY|O_LARGEFILE) = 3
8037  fstat64(3, {st_dev=makedev(8, 3), st_ino=3499728, st_mode=S_IFREG|0644,
st_nlink=1, st_uid=0, st_gid=0, st_blksize=4096, st_blocks=9784,
st_size=4992010, st_atime=2006/11/08-09:53:00, st_mtime=2004/11/08-16:33:07,
st_ctime=2006/10/04-10:02:02}) = 0
8037  mmap2(NULL, 4992010, PROT_READ, MAP_SHARED, 3, 0) = 0xb790d000
8037  fstat64(1, {st_dev=makedev(0, 9), st_ino=10, st_mode=S_IFCHR|0620,
st_nlink=1, st_uid=0, st_gid=5, st_blksize=1024, st_blocks=0,
st_rdev=makedev(136, 8), st_atime=2006/11/08-09:53:24,
st_mtime=2006/11/08-09:53:24, st_ctime=2006/11/07-11:17:46}) = 0
8037  mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0)
= 0xb790c000
8037  write(1, "B\n", 2)                = 2
8037  write(1, "B\'s\n", 4)             = 4
...

Comment 1 Shing-Shong Shei 2006-11-17 16:37:49 UTC
Hi Karel,

Did you get a chance to look into this?

Thanks,
Bruce


Comment 2 Shing-Shong Shei 2006-12-02 16:18:20 UTC
Hi,

I am really surprised about the service of RH?  No one
even reply saying that he or she will look into it even
though this is apparently a low priority case.  But no
acknowledgement at all to my inquiry does not seem to
be right to me.

Thanks,
Bruce


Comment 3 Karel Zak 2006-12-02 18:21:06 UTC
Sorry, but this is *not* support service. Please, use
http://www.redhat.com/apps/support/. 

*** This bug has been marked as a duplicate of 153276 ***

Comment 4 Shing-Shong Shei 2006-12-02 18:56:18 UTC
Thanks for the info, Karel.  Have a good weekend.  --Bruce


Note You need to log in before you can comment on or make changes to this bug.