Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 213390 - ghostscript mangles OpenType Hebrew font
Summary: ghostscript mangles OpenType Hebrew font
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ghostscript
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: F7Update
TreeView+ depends on / blocked
 
Reported: 2006-11-01 09:26 UTC by A. Folger
Modified: 2008-02-26 16:27 UTC (History)
0 users

Fixed In Version: F-8
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-26 16:27:25 UTC


Attachments (Terms of Use)
the Ezra SIL OpenType font (deleted)
2006-11-01 09:26 UTC, A. Folger
no flags Details
OOo file with text, with vowel points and cantillation, typeset with the Ezra SIL font (deleted)
2006-11-01 09:39 UTC, A. Folger
no flags Details

Description A. Folger 2006-11-01 09:26:50 UTC
Description of problem:
Ghostscript mangles documents containing Hebrew written with, for example, the
Ezra SIL OpenType font.

Version-Release number of selected component (if applicable):
ghostscript-8.15.2-1.1.i386.rpm

How reproducible:
Every time. Use attached openoffice file as example. The font is also attached.

Steps to Reproduce:
1. Create Hebrew text with Ezra SIL font. Sometimes smaller text (10pt, etc.)
will print correctly, but anything above 12pt will demonstrate the bug
2. print the document
3. 
  
Actual results:

The Ezra SIL Hebrew letters are only partially printed.

Expected results:

Well printed letters.

Additional info:
The use of such OpenType fonts like Ezra SIL is quite important for those who
want to work with vowel-points (= niqud/nikud; Hebrew is a consonantal script,
usually written without vowels, except for education, ritual and exceptional
uses) and cantillation marks (for biblical passages). OpenOffice currently does
not properly display and print vowel points and catillation of non-OpenType
fonts (you can get more info by searching for "nikud" on the openoffice.org bug
reporting site)

Comment 1 A. Folger 2006-11-01 09:26:52 UTC
Created attachment 139955 [details]
the Ezra SIL OpenType font

Comment 2 A. Folger 2006-11-01 09:33:11 UTC
The version numbers I gave above are from my fully updated FC5-i386 box at work,
but at home I am testing FC6-x86_64, and the same problem arose.

Comment 3 A. Folger 2006-11-01 09:39:39 UTC
Created attachment 139956 [details]
OOo file with text, with vowel points and cantillation, typeset with the Ezra SIL font

There is voweled Hebrew text on both pages, cantillation marks are only
included at the bottom of page two.

To see the bug, even if you are a non-Hebrew reader, just print the document
using the buggy version of Ghostscript, and print it again with the older,
non-buggy version, and compare. If the difference isn't sufficiently apparent
(I doubt that), just enlarge the Hebrew text, first.

Note that the problem is mostly with displaying the horizontal stokes.

Comment 4 Tim Waugh 2008-02-26 11:40:31 UTC
Do you still see this problem?  Which version of ghostscript last worked
correctly for you?

Comment 5 A. Folger 2008-02-26 13:30:27 UTC
I haven't seen this problem recently. I am now using Fedora 8.


Note You need to log in before you can comment on or make changes to this bug.