Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 213356 - Anaconda crashes with unhandled exception when DHCP fails on Extras install
Summary: Anaconda crashes with unhandled exception when DHCP fails on Extras install
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
: 217314 231920 232090 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-01 00:35 UTC by Bernard Johnson
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-11-06 15:12:07 UTC


Attachments (Terms of Use)

Description Bernard Johnson 2006-11-01 00:35:56 UTC
Description of problem:
I selected Fedora Extras as an additional repository.  It tried to get a DHCP
address, but I didn't have a cable plugged in to eth0.  After some amount of
time (approximately 30 seconds) an unhandled exception occurred.

Version-Release number of selected component (if applicable):
FC6-release anaconda

How reproducible:


Steps to Reproduce:
1. Select FE repository
2. unplug ethernet cable
3. wait for error
  
Actual results:
Traceback (most recent call first):
 File "/usr/lib/anaconda/iw/netconfig_dialog.py", line 215, in _ok
  _("Error configuring network device"))
TypeError: parent should be a GtkWindow or None

Local variables in innermost frame:
val: eth0
netdev: DEVICE=eth0
BOOTPROTO=dhcp
HWADDR=xx:xx:xx:xx:xx:xx
ONBOOT=yes

self: <netconfig_dialog.NetworkConfigurator instance at 0xa9cf6cc>
args: (<gtk.Button object (GtkButton) at 0xaada07c>,)
w: <gui.WaitWindow instance at 0xa9c75ec>
combo: <gtk.ComboBox object (GtkComboBox at 0xaada0a4>
active: <GtkTreelter at 0xa580ab8>
ns: None

... etc

Expected results:
Actually, I would have expected anaconda to realize that there was no link on
the device, but instead it happily tries to get a DHCP address.  At least if
it's going to do this, it should fail gracefully.

Additional info:
I might also note that it says "An unhandled exception has occurred.  This is
most likely a bug.  Please save a copy of the detailed exception and file a bug
report against anaconda at http://bugzilla.redhat.com"

1) It is missing the ending period.
2) There is probably 20 pages of exception information.  How does one go about
"saving a copy" without manually typing on another computer?

Comment 1 Jeremy Katz 2006-11-06 15:12:07 UTC
That was actually good enough for this one; fixed in CVS.

In general, saving to a floppy/memory stick or using the save to remote is the
way to grab it.  In this case, the latter is a little harder

Comment 2 Chris Lumens 2006-11-27 19:40:39 UTC
*** Bug 217314 has been marked as a duplicate of this bug. ***

Comment 3 Chris Lumens 2007-03-13 14:11:25 UTC
*** Bug 231920 has been marked as a duplicate of this bug. ***

Comment 4 Chris Lumens 2007-03-14 18:25:55 UTC
*** Bug 232090 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.