Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 213285 - perl INC path is missing locations on ppc64
Summary: perl INC path is missing locations on ppc64
Keywords:
Status: CLOSED DUPLICATE of bug 235553
Alias: None
Product: Fedora
Classification: Fedora
Component: perl
Version: 6
Hardware: powerpc
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-31 16:43 UTC by Kumar Gala
Modified: 2008-02-21 15:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-02-21 15:09:17 UTC


Attachments (Terms of Use)

Description Kumar Gala 2006-10-31 16:43:50 UTC
Description of problem:

the perl @INC path is missing the 'ppc' vendor path
(/usr/lib/perl5/vendor_perl/5.8.8/ppc-linux-thread-multi/)

Which is where certain perl modules are built and installed (perl-HTML-Parser)

Version-Release number of selected component (if applicable):

perl-5.8.8-10
perl-HTML-Parser-3.55-1.fc6

How reproducible:

A simple perl script which report the @INC path:

print " @INC ";


Steps to Reproduce:
1. perl test.pl
  
Actual results:


/usr/lib64/perl5/site_perl/5.8.8/ppc64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.7/ppc64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.6/ppc64-linux-thread-multi
/usr/lib64/perl5/site_perl/5.8.5/ppc64-linux-thread-multi
/usr/lib/perl5/site_perl/5.8.8 /usr/lib/perl5/site_perl/5.8.7
/usr/lib/perl5/site_perl/5.8.6 /usr/lib/perl5/site_perl/5.8.5
/usr/lib/perl5/site_perl
/usr/lib64/perl5/vendor_perl/5.8.8/ppc64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.7/ppc64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.6/ppc64-linux-thread-multi
/usr/lib64/perl5/vendor_perl/5.8.5/ppc64-linux-thread-multi
/usr/lib/perl5/vendor_perl/5.8.8 /usr/lib/perl5/vendor_perl/5.8.7
/usr/lib/perl5/vendor_perl/5.8.6 /usr/lib/perl5/vendor_perl/5.8.5
/usr/lib/perl5/vendor_perl /usr/lib64/perl5/5.8.8/ppc64-linux-thread-multi
/usr/lib/perl5/5.8.8 .

Expected results:

Should also have

/usr/lib/perl5/vendor_perl/5.8.8/ppc-linux-thread-multi/

Should have 

Additional info:

Comment 1 Kumar Gala 2006-10-31 16:56:44 UTC
The other solution maybe that perl modules may also need ppc64 builds.

When I hacked in perl script to explicilty include
/usr/lib/perl5/vendor_perl/5.8.8/ppc-linux-thread-multi/ I got the following
message:

Can't load
'/usr/lib/perl5/vendor_perl/5.8.8/ppc-linux-thread-multi/auto/HTML/Parser/Parser.so'
for module HTML::Parser:
/usr/lib/perl5/vendor_perl/5.8.8/ppc-linux-thread-multi/auto/HTML/Parser/Parser.so:
wrong ELF class: ELFCLASS32

Comment 2 Kumar Gala 2006-10-31 16:59:25 UTC
Doing a rebuild of perl-HTML-Parser-3.55-1.fc6.src.rpm on a ppc64 host ends up
generating perl-HTML-Parser-3.55-1.fc6.ppc64.rpm which when installed resolves
the issue with my specific script.

Comment 3 Marcela Mašláňová 2008-02-21 15:09:17 UTC

*** This bug has been marked as a duplicate of 235553 ***


Note You need to log in before you can comment on or make changes to this bug.