Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 213043 - Software Updater Issues
Summary: Software Updater Issues
Keywords:
Status: CLOSED DUPLICATE of bug 213963
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 6
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-30 17:40 UTC by Krisstoffer
Modified: 2014-01-21 22:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-27 18:07:50 UTC


Attachments (Terms of Use)
traceback report (deleted)
2006-10-30 17:40 UTC, Krisstoffer
no flags Details

Description Krisstoffer 2006-10-30 17:40:31 UTC
Description of problem:
Software Updater crashes on usage

Version-Release number of selected component (if applicable):
unknown

How reproducible:
unknown - see attached

Steps to Reproduce:
  
Actual results:
crash with traceback

Expected results:


Additional info:
See atttached file probably more helpful than any information ( which is little
) that i have provided. The component listed in the traceback is listed as
software updated, this doesnt appear listed thus rpmdb was the next best thing.

Comment 1 Krisstoffer 2006-10-30 17:40:32 UTC
Created attachment 139732 [details]
traceback report

Comment 2 Jeff Johnson 2006-10-30 18:49:34 UTC
This problem is with yum, so the component should be changed.

Comment 3 Seth Vidal 2006-11-16 20:26:36 UTC
what system is this on?

could you run:

rpm -q --whatprovides redhat-release 

for me?

thanks

Comment 4 Krisstoffer 2006-11-16 20:54:27 UTC
hello 
this appears to fix it, it has come back once or twice.
rm /var/lib/rpm/__db*
rpm --repairddb

output of requested is:
fedora-release-6-4

the above happened on a fresh install without modification ( new repos etc etc
just "as is shipped"

Comment 5 Jeff Johnson 2006-12-03 18:44:45 UTC
Segafualts and loss of data are likely due to removing an rpmdb environment
without correcting other problems in the rpmdb.

FYI: Most rpmdb "hangs" are now definitely fixed by purging stale read locks when opening
a database environment in rpm-4.4.8-0.4. There's more todo, but I'm quite sure that a
large class of problems with symptoms of "hang" are now corrected.

Detecting damaged by verifying when needed is well automated in rpm-4.4.8-0.4. Automatically 
correcting all possible damage is going to take more work, but a large class of problems is likely
already fixed in rpm-4.4.8-0.8 as well.

UPSTREAM

Comment 6 martin kovarik 2007-01-25 06:14:47 UTC
the similar problem. bug report:
Component: Software Updater
Summary: TB8a9160cb comps.py:143:parse_package_list:CompsException

Traceback (most recent call last):
  File "/usr/sbin/pup", line 659, in ?
    main()
  File "/usr/sbin/pup", line 655, in main
    pup.run()
  File "/usr/sbin/pup", line 494, in run
    self.doRefresh()
  File "/usr/sbin/pup", line 269, in doRefresh
    self.reposSetup(pbar)
  File "/usr/lib/python2.4/site-packages/pirut/__init__.py", line 153, in reposSetup
    self.doGroupSetup()
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 408, in doGroupSetup
    self.comps.add(groupfile)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 339, in add
    group = Group(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 57, in __init__
    self.parse(elem)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 133, in parse
    self.parse_package_list(child)
  File "/usr/lib/python2.4/site-packages/yum/comps.py", line 143, in
parse_package_list
    raise CompsException
CompsException

Local variables in innermost frame:
genre: optinoal
self: Graphics
package: digikam
packagelist_elem: <Element 'packagelist' at 0xa18fcb0>
child: <Element 'packagereq' at 0xa18fc20>

I do not know what to do...
makov

Comment 7 Bill Wadley 2007-01-26 03:55:23 UTC
This last report appears identical to bug #224292. Ya'll should check it out.
The instructions regarding 'yum clean all' and then 'yum -y update' appear to
have worked for me (with my dump identical to your last one).

Comment 8 Red Hat Bugzilla 2007-08-21 05:27:55 UTC
User pnasrat@redhat.com's account has been closed

Comment 9 Panu Matilainen 2007-08-22 06:32:23 UTC
Reassigning to owner after bugzilla made a mess, sorry about the noise...

Comment 10 Panu Matilainen 2007-08-27 18:07:50 UTC
Apart from comment 6, the random crashes etc are almost certainly results of
kernel 2.6.18-19 mmap() bug.

*** This bug has been marked as a duplicate of 213963 ***


Note You need to log in before you can comment on or make changes to this bug.