Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 213 - ping -f localhost on 2.1.x kernels shows high packet loss
Summary: ping -f localhost on 2.1.x kernels shows high packet loss
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: netkit-base
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
: 146 1284 2238 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-11-28 09:59 UTC by Marc MERLIN
Modified: 2008-05-01 15:37 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-11 15:55:45 UTC


Attachments (Terms of Use)

Description Marc MERLIN 1998-11-28 09:59:18 UTC
I added the following information to bug 146, but since it
was marked at DISCARDed, I don't known if my edits made
it to anyone (I didn't receive mail confirmation from
bugzilla).

This is an FAQ on linux kernel:
moremagic:~# ping -f localhost
PING localhost (127.0.0.1): 56 data bytes
...................................................................................................................................................................................................................................................................................................................................................
--- localhost ping statistics ---
677 packets transmitted, 338 packets received, 50% packet
loss
round-trip min/avg/max = 0.4/443.7/708.2 ms

There is a known problem with the ping binary that comes
with most distributions, and I was hoping RH 5.2 would have
the fixed version.
Please look at:
http://www.egroups.com/list/linux-kernel/77859.html
http://www.egroups.com/list/linux-kernel/78066.html

(If you don't know who Alexey Kuznetsov is, he did a _lot_
of TCP/IP work in the 2.1 kernels)

Comment 1 Jeff Johnson 1999-03-09 04:49:59 UTC
*** Bug 1284 has been marked as a duplicate of this bug. ***

{1252}$ sudo ping -f localhost
Password:
PING localhost.localdomain (127.0.0.1): 56 data bytes
............................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................---
localhost.localdomain ping statistics ---
1596 packets transmitted, 1 packets received, 99% packet
loss
round-trip min/avg/max = 0.567/0.567/0.567 ms

I have heard the latest ping in iputils works properly, alan
cox seems to know the details.

Comment 2 Preston Brown 1999-03-30 17:01:59 UTC
Jeff this is still screwed in netkit-base-0.10-26.  Do you have that
patch from alan?

Comment 3 Marc MERLIN 1999-03-31 06:47:59 UTC
It wasn't a piece of cake to find the patch, but here is the message
you're looking for:
http://www.uwsg.indiana.edu/hypermail/linux/kernel/9811.2/0818.html
and the patch:
http://www.alfie.demon.co.uk/download/ping.diff.gz

Comment 4 Jeff Johnson 1999-03-31 14:15:59 UTC
Apparently ping flood can transmit faster than it can receive
so the patch "staunches the flow". Thanks for the patch.

I don't understand the Kusnetsov ping. The code is seriously
different and I'm reluctant to fix ping if it ain't broke ...

Comment 5 Jeff Johnson 1999-04-17 17:21:59 UTC
*** Bug 146 has been marked as a duplicate of this bug. ***

Try

ping -f localhost as root it should be obvious:

--- localhost ping statistics ---
1847 packets transmitted, 177 packets received, 90% packet
loss
round-trip min/avg/max = 0.9/42.4/84.9 ms

90% is bad...

------- Additional Comments From pbrown@redhat.com  11/20/98 06:44 -------
Not a bug, you are flood pinging.  Not every ping request will come
back.

You are hammering the networking code in the kernel, it can't keep up.

------- Additional Comments From marcsoft@merlins.org  11/28/98 01:59 -------
Actually Pavel is most likely using a recent 2.1 kernel. There is a
known problem with the ping binary.
Please look at:
http://www.egroups.com/list/linux-kernel/77859.html
http://www.egroups.com/list/linux-kernel/78066.html

(If you don't know who Alexey Kuznetsov is, he did a _lot_ of TCP/IP
work in the 2.1 kernels)

Comment 6 Jeff Johnson 1999-04-17 17:23:59 UTC
*** Bug 2238 has been marked as a duplicate of this bug. ***

The ping in netkit-base is bad.  See the endless
discussion on linux-kernel for more info.

A well-behaved ping is part of iproute utils.  I forget
the url, but it's listed in the Changes file.

Comment 7 Marc MERLIN 1999-04-21 18:54:59 UTC
Here's a recent message from Alexey about ping in linux-kernel:
---
From: kuznet@ms2.inr.ac.ru
Newsgroups: lists.linux.kernel
Subject: Re: Linux ping flood on localhost
Date: 16 Apr 1999 11:50:21 -0700
Organization: Magic Mail <-> News Gateway

Hello!

> So where do I get a ping later than what is shown in
/linux/Documentation

Debian includes more or less sane ping.
Redhat folks are less reactive, but I did not see 5.9 yet.

Good ping may be found at ftp://ftp.inr.ac.ru/iputils-current.tar.gz,
though it will not compile for linux-2.0. Debian's one is more
"portable".

Alexey
---
Another message later says that a correct URL is:
http://ftp.sunet.se/ftp/pub/network/ip-routing/

BTW, it'd be nice if bugzilla would let me add something to a bug
without re-opening it...

Comment 8 Jeff Johnson 1999-05-11 15:55:59 UTC
netkit-base-0.10-30.src.rpm contains Kuznetzsov ping.


Note You need to log in before you can comment on or make changes to this bug.