Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 212752 - yum error: "IOError: <urlopen error unknown url type: media>"
Summary: yum error: "IOError: <urlopen error unknown url type: media>"
Keywords:
Status: CLOSED DUPLICATE of bug 212180
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 6
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-28 18:43 UTC by Sam Varshavchik
Modified: 2014-01-21 22:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-29 02:51:56 UTC


Attachments (Terms of Use)

Description Sam Varshavchik 2006-10-28 18:43:17 UTC
Description of problem:

Yum returns a confusing error when pointed to a DVD image on an external HTTP
server.

Version-Release number of selected component (if applicable):

3.0-6

How reproducible:

Always

Steps to Reproduce:

1. Take the FC 6 DVD image, and put it into /var/www/html on a server running
Apache.
2. On another server, create a suitable yum.repos.d entry pointing to the DVD
image, and disable the fedora-core.repo repository.
3. Run 'yum install' package.

  
Actual results:

# yum install gnome-vfs2.x86_64 libgcj.x86_64 libgnome.x86_64 libbonoboui.x86_64
libgnomeui.x86_64
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
fedora-core-local         100% |=========================| 1.3 kB    00:00     
Reading repository metadata in from local files
primary.xml.gz            100% |=========================| 870 kB    00:00     
################################################## 2931/2931
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Downloading header for libgcj to pack into transaction set.
media://1161132068.269978%232/Fedora/RPMS/libgcj-4.1.1-30.x86_64.rpm: [Errno 4]
IOError: <urlopen error unknown url type: media>
Trying other mirror.
Error: failed to retrieve Fedora/RPMS/libgcj-4.1.1-30.x86_64.rpm from
fedora-core-local
error was [Errno 4] IOError: <urlopen error unknown url type: media>

Expected results:

Yum installs the package, or tell me why it cannot install it.

Additional info:

Whether or not this functionality is supported by yum, if this particular
configuration is not supported, I want it to tell me so, instead of blurting out
this completely content-free diagnostic.

I defined the repositry, in yum.repos.d, as follows:

[fedora-core-local]
name=Local copy of Fedora Core
baseurl=http://headache/dvd/
enabled=0
gpgcheck=0


"http://headache/dvd" is the root of the DVD image of FC6:

 Icon  Name                       Last modified      Size  Description          
                                                                                
   ══════════════════════════════════════════════════════════════════════════   
                                                                                
 [DIR] Parent Directory                                -                        
 [DIR] Fedora/                    17-Oct-2006 20:18    -                        
 [TXT] GPL                        05-Apr-2005 14:35   18K                       
 [TXT] RELEASE-NOTES-en_US.html   17-Oct-2006 16:42  172K                       
 [TXT] RPM-GPG-KEY                15-Oct-2006 14:07  1.9K                       
 [TXT] RPM-GPG-KEY-beta           15-Oct-2006 14:07  1.7K                       
 [   ] RPM-GPG-KEY-fedora         15-Oct-2006 14:07  1.5K                       
 [   ] RPM-GPG-KEY-fedora-extras  15-Oct-2006 14:07  2.0K              

...

etc...

If you notice in yum's output, it did succesfully download primary.xml's
contents, and processed it; then barfed when it tried to download the package.

Comment 1 Dale Stimson 2006-10-29 00:57:32 UTC
A duplicate of bug 212180

Comment 2 Sam Varshavchik 2006-10-29 02:51:56 UTC
Yes, I wasn't going crazy.  This definitely worked in FC5 and earlier, and
there's no reason why it should not work any more.


*** This bug has been marked as a duplicate of 212180 ***


Note You need to log in before you can comment on or make changes to this bug.