Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 212711 - Non-DHCP install causes anaconda exception
Summary: Non-DHCP install causes anaconda exception
Keywords:
Status: CLOSED DUPLICATE of bug 212018
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 6
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-10-28 08:39 UTC by Jeff Garzik
Modified: 2013-07-03 02:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-30 02:25:22 UTC


Attachments (Terms of Use)

Description Jeff Garzik 2006-10-28 08:39:08 UTC
Description of problem:
Summary:  DHCP install works.  Non-DHCP install causes exception, when clicking
on the 'Fedora Extras' checkbox on the Repositories screen.

Machine:  ICH7 Intel SDV box.

Baseline:  FC6 x86-64 DVD install completes successfully, when using the default
(100% DHCP) network settings.

Problem case:  FC6 x86-64 DVD install crashes with a Python exception. 
Variation from baseline:  (a) entering a manual IPv4 address, netmask, primary
DNS server, and gateway.  IPv6 checkbox is unchecked, disabling IPv6.

Version-Release number of selected component (if applicable):
FC6 GA

How reproducible:
Always.

Steps to Reproduce:
1. Enter manual IPv4 address/netmask/gateway/DNS, rather than using DHCP.
2. Un-check the IPv6 checkbox, disabling IPv6.
3. Proceed through screens, until you reach the Repositories screen.
4. Check the Fedora Extras checkbox (which initiates the
activate-network-interface dialog).
  
Actual results:
Python exception, installer crash, kernel halt.

Expected results:
Installation proceeds, like it does with the all-DHCP install.

Comment 1 Chris Lumens 2006-10-30 02:25:22 UTC

*** This bug has been marked as a duplicate of 212018 ***


Note You need to log in before you can comment on or make changes to this bug.