Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 2126 - xscreensaver cannot check password (xscreensaver-3.08-4)
Summary: xscreensaver cannot check password (xscreensaver-3.08-4)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: pam
Version: 6.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 2164 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-04-11 17:57 UTC by rh2021
Modified: 2008-05-01 15:37 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-05-06 14:48:37 UTC


Attachments (Terms of Use)

Description rh2021 1999-04-11 17:57:00 UTC
xscreensaver seems to be having problems with shadow'd
passwords.
    errors in .xsession-errors say

xscreensaver-command: xscreensaver window has been deleted.
xscreensaver: couldn't get password of "smooge"
xscreensaver: couldn't get password of "root"

    Symptom is that you cant type any password to turn off
xscreensaver
    once it starts up. I have to ALT-F1 and kill it from
there.

    strace indicates a permission denied when the program
tries to read
    /etc/shadow (which I would think is a good thing).
However, I
    thought there would be some sort of PAM thing going on
for
    authentication that doesnt seem to happen (xscreen
"forgot" to use
    PAM?)

xscreensaver-3.08-4
pam-0.66-11

    couldnt duplicate at work because passwords are in the
YP password
    field.

Comment 1 rh2021 1999-04-11 19:23:59 UTC
Downgrading pam to pam-0.66-4 fixed the problem. Something between
-4 and -11 is causing xscreensaver to not "work".

Comment 2 Bill Nottingham 1999-04-12 16:03:59 UTC
using xscreensaver-3.08-4 & pam-0.66-11, xscreensaver
prints those error messages on startup, but does lock
and unlock the screen correctly (this is in the test
lab). What does your /etc/pam.d/xscreensaver say?

Comment 3 Preston Brown 1999-04-13 20:59:59 UTC
*** Bug 2164 has been marked as a duplicate of this bug. ***

The update to xscreensaver-2.0.9 in the current build
cases the password entry prompt to always fail.

To reproduce: lock screen, tap a key, try to enter user's
password, it will always fail

------- Additional Comments From notting@redhat.com  04/13/99 10:06 -------
Arrgh. Everyone can duplicate this except me.
- are you using shadow passwords (I'm assuming yes)
- are you using NIS (I'm assuming no)
What version of PAM are you running?
It looks like we might have to turn the setuid bit back on.

Comment 4 Bill Nottingham 1999-04-13 21:19:59 UTC
*** Bug 2164 has been marked as a duplicate of this bug. ***

The update to xscreensaver-2.0.9 in the current build
cases the password entry prompt to always fail.

To reproduce: lock screen, tap a key, try to enter user's
password, it will always fail

------- Additional Comments From notting@redhat.com  04/13/99 10:06 -------
Arrgh. Everyone can duplicate this except me.
- are you using shadow passwords (I'm assuming yes)
- are you using NIS (I'm assuming no)
What version of PAM are you running?
It looks like we might have to turn the setuid bit back on.


------- Additional Comments From pbrown@redhat.com  04/13/99 16:59 -------


*** This bug has been marked as a duplicate of 2126 ***

Comment 5 Bill Nottingham 1999-04-14 00:21:59 UTC
This seems to be a bug in /sbin/pwdb_chkpwd, as xscreensaver
is properly doing pam authenticate calls.

Comment 6 Bill Nottingham 1999-05-06 14:48:59 UTC
fixed in some later pwdb release before 6..0


Note You need to log in before you can comment on or make changes to this bug.