Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 21241 - Enhancement to rpm -F option
Summary: Enhancement to rpm -F option
Keywords:
Status: CLOSED DUPLICATE of bug 7771
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm
Version: 7.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-11-22 14:15 UTC by Jan "Yenya" Kasprzak
Modified: 2007-03-27 03:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2000-11-22 14:15:48 UTC


Attachments (Terms of Use)

Description Jan "Yenya" Kasprzak 2000-11-22 14:15:45 UTC
When upgrading Red Hat Linux using rpm -Fvh <redhat>/updates/7.0/i386/*
the upgrade fails on some systems, when there are multiple versions
of the same package and at least two of them are newer than the package
currently installed. Then rpm -F tries to install _both_ newer version
and, of course, fails because the two versions of the same package
usually conflicts with each other.

The good example is the stock install of Red Hat 7.0 and the
glibc packages (in updates/i386 there are currently two versions of
glibc - 2.1.9x and 2.2).

I think it would be better if rpm tries to install only the newest
of multiple packages of the same base name given on the command line.

Comment 1 Jeff Johnson 2001-01-09 16:09:32 UTC
Collecting duplicates at bugzilla #7771.

*** This bug has been marked as a duplicate of 7771 ***


Note You need to log in before you can comment on or make changes to this bug.